Support » Plugin: Disable REST API » Translate

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Dave McHale

    (@dmchale)

    Hi @jsy68

    Thanks for the note Jenny, that’s my misunderstanding of how the i18n system was working. I thought all installs used translate.wordpress.org as their default source now, and didn’t realize that was only a thing in WordPress 4.6 and later. I definitely want to support earlier versions of WP than that, so I’ll make sure that load_plugin_textdomain() gets added to support older versions of WP. I should have a new version up in a day or two with it added. Cheers!

    Hi,

    OK.
    Don’t hesitate to tell me when translation will be possible.

    Thanks

    Hi Dave,

    I would also contribute with translations into formal and default german. 🙂

    Thanks for the plugin!

    Plugin Author Dave McHale

    (@dmchale)

    @jdy68 and/or @transl8or

    Are you able to test the i18n functionality with an in-development version of the plugin? I just pushed an update to github, if you can test that and confirm it works as expected before I push to the wp.org repository https://github.com/dmchale/disable-json-api

    It may be a small change, but I want to make sure it’s working right before rolling it out publicly and finding out another small update is necessary.

    Thanks! And sorry for the delay

    @dmchale, I don’t really have test possibilities towards github, but your textdomain seems to be set and correctly used from what I see and you load your text domain.

    So globally speaking, you seem to be ready, but the system will tell you if anything is missing 🙂

    Hi Dave,
    you better wait until tomorrow or tuesday.
    I would ask someone like @ocean90 for your i18n functionality test of your changes and until the servers are all up and running 100% again. There seem to be some issues since this weekend too.
    He’s the man for that too but is propably eating lot’s of cake today 😉 and back with us here on the 5th. Or try to get him on Slack.

    (I downloaded and installed your latest github version and it works as expected, but concerning the actual issue for being translation-ready now … I’m not sure.)

    Cheers & Happy Sunday to y’all!

    WP-Translations

    (@wptranslationsorg)

    Hi,

    If you want to make sure your plugin is i18n ready you can use the service of WP-Translations. We’ll make sure by testing your plugin in a dedicated WordPress sandbox site that your plugin is ready to hit on wp.org.

    Get in touch if you have any questions.
    FX

    Plugin Contributor Tang Rufus

    (@tangrufus)

    Sorry guys, it’s my bad.
    I misguided @dmchale to remove load_plugin_textdomain() form the codebase without realizing it is required for Requires at least: 4.4.

    Plugin Author Dave McHale

    (@dmchale)

    @tangrufus No worries at all, honestly this is a blessing in disguise since the old code was in the class that only runs in WP 4.7+ anyway. With the code added back in where I put it in the main file, we’ll always run load_plugin_textdomain() (which we should)

    Thanks for the heads up on the server issues @transl8or , I’ll push the new version to the repo tomorrow (Tuesday) to try and give things a chance to calm down on that front.

    And cheers for taking a look @casiepa ! Appreciate the confirmation.

    Plugin Author Dave McHale

    (@dmchale)

    @jdy68 @transl8or If either of you would like to work on translations, I’ve uploaded 1.4.3 to the repository so I think we should be good for you now. https://wordpress.org/plugins/disable-json-api/

    Thanks for your patience! I’m going to close this ticket as resolved now, but do let me know if you have any issues. Cheers!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Translate’ is closed to new replies.