WordPress.org

Support

Support » Installation » [Resolved] Transferring files from wordpress subdirectory

[Resolved] Transferring files from wordpress subdirectory

  • goldmember
    Participant

    @goldmember

    i’ve built a new version of this site: http://www.goldcoastchamber.com/ here in a wordpress subdirectory: http://www.goldcoastchamber.com/wordpress/

    now that i’m finished, i’m ready to transition the new wordpress over and replace the existing. is it as simple as moving all the files up one level, out of the wordpress folder subdirectory and into the main root folder? or is there something i need to do with the database connection? if so, what?

    thanks in advance!

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi
    Forum Moderator

    @esmi

    goldmember
    Participant

    @goldmember

    thanks. but that helps. but someone had told me i “need to EXPORT the staging DB via phpMyAdmin (or whatever you use to manage the MySQL for them) and then IMPORT on the new location via the same tool.”

    is this true? how come there’s no mention of the database in that tutorial?

    jonradio
    Participant

    @adiant

    No, the phpMyAdmin EXPORT/IMPORT is only required if you move to a new domain name — actually, technically to a new subaccount, account or web host.

    The requirement for the database move is based on whether or not you can still access the old database from your new location.

    goldmember
    Participant

    @goldmember

    ok, so i tried to transition it up to the root directory, following the tutorial. the only thing that seems to be appearing is the stuff in the left nav bar: http://www.goldcoastchamber.com/

    i’m guessing hte problem has something to do with the message at the top “Rendering of template head.php failed”. what does this mean and how do i fix? thanks!

    goldmember
    Participant

    @goldmember

    by the way, i’m now getting the following message at http://www.goldcoastchamber.com/:

    Warning: main(/wordpress/wp-blog-header.php): failed to open stream: No such file or directory in /home/content/b/r/i/brineu21/html/index.php on line 17

    Warning: main(/wordpress/wp-blog-header.php): failed to open stream: No such file or directory in /home/content/b/r/i/brineu21/html/index.php on line 17

    Fatal error: main(): Failed opening required ‘/wordpress/wp-blog-header.php’ (include_path=’.:/usr/local/lib/php’) in /home/content/b/r/i/brineu21/html/index.php on line 17

    the line in my index.php file that i was supposed to change now says “require(‘/wordpress/wp-blog-header.php’);

    please advise. thanks.

    goldmember
    Participant

    @goldmember

    and i dont know if it will help, but here’s a look at what files i have on my remote site: http://www.goldcoastchamber.com/pics/sample.jpg

    additionally, i can no longer login to my wp-login page: http://www.goldcoastchamber.com/wordpress/wp-login. for some reason the wp-login screen looks very different now and when i enter my name and password, i get an error screen: “Page Not Found. The page you tried to access does not exist on this server….”

    please please please help!!!! thanks.

    Heh, I regged just to post an observation for ya, although I may use WP soon here.

    Your paths ain’t setup right mate.

    Check the URL/Server Paths for the CSS/scripts that’s failing.

    This one in the source is incorrect:
    http://www.goldcoastchamber.com/wp-admin/css/login.css

    When I tried this URL, it found the CSS for your Admin area:
    http://www.goldcoastchamber.com/wordpress/wp-admin/css/login.css

    I’m guessing other paths are similarly confused. 😉

    The main site works using http://www.goldcoastchamber.com/wordpress/ but the CSS isn’t there either.

    You main banner won’t show at http://www.goldcoastchamber.com/wp-content/themes/wp-andreas01/img/front.jpg as it’s set now, but it IS at http://www.goldcoastchamber.com/wordpress/wp-content/themes/wp-andreas01/img/front.jpg

    See what I mean?

    If ya can’t login to edit your configs, just use FTP and a Text/HTML Editor like Notepad, don’t use Word or Wordpad…they can mess up encoding & formatting.

    I like EditPlus personally as it can FTP and edit directly.

    GL,

    ~DG

    goldmember
    Participant

    @goldmember

    thanks.

    so on my remote site, should I have everything in a wordpress folder subdirectory? or all my stuff should reside in the main root directory?

    and whichever instance you suggest, how should i structure this line in my index.php file? “require(‘/wordpress/wp-blog-header.php’);”

    and should that index.php file be in the root folder or wordpress subdirectory?

    please advise. thanks.

    goldmember
    Participant

    @goldmember

    so i think i need to backtrack a few steps. and i re-uploaded my original files back to the original wordpress subdirectory. before i deal with transitioning things to my main root directory, i’d like to at least get the subdirectory issues straightened out.

    as you can see, http://www.goldcoastchamber.com/wordpress/ and http://www.goldcoastchamber.com/wordpress/wp-login, things are out of whack. the pages aren’t finding the css files and content files that should be feeding them. i think it has to do with the fact that before i started messing with things, i was in the admin screen and changed the URIs from http://www.goldcoastchamber.com/wordpress/. But now that my admin screen (i.e. wp-login) is screwed up, i cant even log back in to change them back.

    please advise how i should proceed from here??? thanks!!!!

    goldmember
    Participant

    @goldmember

    ok, making some progress now. i got everything but the pictures from the postings and pages to appear: http://www.goldcoastchamber.com/

    is there any way to get the pics to appear without going into each page and posting, one by one?

    please advise. thanks!

    goldmember
    Participant

    @goldmember

    actually i got the pics fixed!!!!

    but on my Member Directory page (http://www.goldcoastchamber.com/?page_id=36), the links to the different categories do not work.

    any idea how to fix that one? please advise. thanks!

    goldmember
    Participant

    @goldmember

    nevermind, i got that fixed too. thanks.!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Transferring files from wordpress subdirectory’ is closed to new replies.