Support » Installing WordPress » transferring blog from localhost to real server?

  • howdy,

    i’m actually rather new to wordpress. i’ve devoloped a complete blog locally on my mac using MAMP. so i set up a simple database called “wp” wiht phpMyAdmin and used “localhost”,”root” and “root” as hostname, username and password.

    so it’s my first time to transfer this complete stuff (incl. database) on my real server. Though i have some problems:

    first i exported my sql-database with phpMyAdmin from my localhost, copied all the code, and visited my real server’s phpMyAdmin and pasted it in. after saving this, all tables are completely the same as on my localhost. wo i guess, maybe that step is RIGHT, isn’t it?

    second i transferred all wordpress-files to my real server.
    and third, i edited the wp-config.php file to match the mysql details i got from my hosting-provider.

    if i now enter the adress of my real server, it’s like there is no PHP-support or something. all i see is a white page, with the following code WRITTEN ON IT:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>

    what i’m doing wrong? thanks for your help and regards
    matt

Viewing 15 replies - 1 through 15 (of 24 total)
  • whooami

    (@whooami)

    Member

    if you see THAT, then php and whatever webserver is being used are not talking, or php isnt even installed.

    talk to the host.

    and dont share your wordpress install location, since your wp-config.php will also be readable until thats resolved.

    ohh, i see. really weird! the hosting provider had PHP5 disabled. now it’s active! however i get a different error!

    ject $wp_locale * @since 2.1.0 */ $wp_locale =& new WP_Locale(); // Load functions for active theme. if ( TEMPLATEPATH !== STYLESHEETPATH && file_exists(STYLESHEETPATH . '/functions.php') ) include(STYLESHEETPATH . '/functions.php'); if ( file_exists(TEMPLATEPATH . '/functions.php') ) include(TEMPLATEPATH . '/functions.php'); /** * Runs just before PHP shuts down execution. * * @access private * @since 1.2.0 */ function shutdown_action_hook() { do_action('shutdown'); wp_cache_close(); } register_shutdown_function('shutdown_action_hook'); $wp->init(); // Sets up current user. // Everything is loaded and initialized. do_action('init'); ?>
    Warning: Cannot modify header information - headers already sent by (output started at /clientdata/n5200-2-dynamic/a/l/mydomainname.com/www/wp-settings.php:706) in /clientdata/n5200-2-dynamic/a/l/mydomainname.com/www/wp-includes/pluggable.php on line 865

    ???

    i found this nice tutorial where everything is nicely explained.
    http://jestro.com/convert-local-wordpress-xampp-installation-into-live-site/

    however i’m not able to change wp_options value to my real domain name! as you can see, he shows the following image case: http://www.jestro.com/wp-content/uploads/2008/09/siteurl.png

    and in my case it looks like this: http://imgur.com/ZDXJn.png and i have no idea where i can change the localhost to my actual domain name?

    would you guys please help me one last time. i really need to get that.
    thanks

    whooami

    (@whooami)

    Member

    youre in the wrong screen in that last image. thats the structure pane. you need to browse the options table, locate the proper row(s) (there are 2 of them), and then edit them (look at the pencil icon on the left hand side of the row)

    In phpMyAdmin go to your database and you will see a list of the tables on the left hand column just under the database title.

    Click on the wp_options and that will bring up the a screen with all the to table components – the very first line option_id 1 will read siteurl under the option name and the location under option_value.

    On the same line if you pan back to the left you will a pencil mark, click on it will bring you to the screeshot given by http://jestro.com/wp-content/uploads/2008/09/siteurl.png – in the space where it reads http://localhost enter your new site name and click Go to save it.

    Go back to the first step above by clicking on wp_options again, scrol down and navigate to the next page using the arrows – on option_id 39 is the line with “home” under the option name, do the same as above and you should be set to go.

    thank you guys. i found it! i changed everything to the complete URL of my site. http://www.test.com

    i saved everything and i checked if it’s really saved! yes it is!!!

    however, i still get this error when i visit my site…have you any ideas what I’m still doing wrong???

    View post on imgur.com

    i have no idea what i’m doing wrong?

    The “headers already sent” error is usually caused by having white space before or after the opening and closing PHP tags (<?php . . . ?>).

    Check any of the files you have edited to make sure there are no blank spaces, especialy before the opening php tag <?php … and be sure to have all plugins (if any installed) deactivated and use the default theme.

    so i should edit my localhost stuff and deactivate all plugins? than export the database again? and i’ll check if there is any whitespace in my files. will do that tonight. develped on my personal mac and now sitting in office where i don’t have these files.

    but that’s the way I should do it, right? first locally deactivate all plugins and then export the mysql database again???

    Yes, best practice is to have nothing active while transfering, installing or upgrading but for the default settings.

    thanks will try that today evening! thank you very much for your help so far

    so now i tried all your suggestions, and it’s almost working. i did everything exactly the same way as it’s described in the tutorial i found. i set everything back to the default. i deaktivated all plugins and set back the default theme. i then exported the sql file again and imported it on my real server. i checked every file i changed for any whitespace in front of the <?php tag.

    it’s now looking like that.
    http://imgur.com/gaIOh.jpg

    the index page is almost working. anyway if i try to go to my wp-admin i still get the whole error: http://imgur.com/bT2In.png

    i don’t get it???

    Can you give the actual site url you are working on

    yeah of course! i will edit this post tomorrow, don’t want to find this in google if you search for the site.

    http://www.allprint.net.au/

    any ideas? i don’t get what’s getting on?

    i just want to know what i’m doing wrong. anyway i think if i don’t get it within today, i’ll just start (almost) from scratch on my real server. will simply add all pages and posts through a simple copy and paste process. will take me less than 2 hours. can’t afford to spend any more time on trying to get it to work.

    whooami

    (@whooami)

    Member

    grab a fresh copy of a wp-settings.php

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘transferring blog from localhost to real server?’ is closed to new replies.