WordPress.org

Support

Support » How-To and Troubleshooting » Transferred DB to new host, now have ? throughout

Transferred DB to new host, now have ? throughout

  • Hello everyone.

    I recently switched hosts and transferred all files via ftp, databases via podz’ guide (http://www.tamba2.org.uk/wordpress/backup/ and the equivalent restore guide), and updated wp-config.

    You can clearly see the problem described in the title at the site:
    alsosprachsara.com/blog (on the new host)
    and it happened again when I moved another blog, so clearly I’m still doing something wrong.

    I’m going to drop the tables and start over. Should I check some other option(s) in phpmyadmin, or do some find/replace with the db text file?

    Thank you so much in advance!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Okay, I’ve figured out a bit more about this problem:

    This is the mark that keeps popping up: �

    I can see it in FireFox 1.5.0.2, but not in a 3 month old IE7 beta. Apparently some others can’t see it in FireFox.

    I’m still baffled!

    It is probably an encoding issue – difference between the two mysql databases.
    What are we supposed to see instead of that question mark? (I see it in FF 1.0.7)

    sounds like a character encoding mismatch to me.

    Looks like one too from the site. In firefox, if you head to view->character encoding and pick “Western (Windows-1252)” those things go away. <<edit: they actually just change, my mistake … but it’s definitely the encoding mismatch that’s the problem>>

    I’d check the charset on the database and see if it matches the encoding you’ve set in wp-admin/options-reading.php.

    This could be the host’s side, serving windows-encoded text but letting you override the listed encoding type, or it could be your db giving you windows encoding and you just needing to match it or change the encoding on the db.

    As far as I can tell, the mark substitutes for the extra space. I always add two spaces after a period. It’s an old habit.

    I’m checking the hosts and their settings now.

    All right, on the host the collation is “latin1_swedish_ci” for some reason. I need to figure out how to change this, preferably in bulk. I’ll be checking back here in case anyone can tell me, and I’ll be looking on Google at the same time.

    This should fix it!

    Ok, I managed to change it in general for the database and one by one for each table. Operations tab at the top. I’ll work on figuring out the sql language for a general command.

    Okay, I made up some sql and it worked, but the question marks remain. Currently all collations are utf8_general_ci. Should I make them just UTF-8? Sounds risky. I tried changing the encoding in WP to utf8_general_ci, but there was no change.

    (Sorry to post so much. I just want to keep people updated.)

    Thank you complich8 and moshu.

    I’ve decided to remove the marks manually in WP, which is lame, but it’s not as bad as you might think.

    I have this exact same problem, except I do not have few enough posts for which it is feasible for me to edit out the question marks. I have 350+ posts mostly long.

    I transferred from Site5.com to Mediatemple and now all of the unusuall chracters (copyright sign, certain apostophe and quotation marks, currency symbols, etc) have all been turned into question marks. Also my database also are listed as “latin1_swedish_ci” just as alsosara’s were on my new host.

    Please any help would be appreciated.

    My url is longorshortcapital.com

    No, your problem is never “exactly the same”.
    alsosara had problems with an odd behaviour where typing “paper-like” (= 2 spaces after period) will result in strange characters.

    Yours is clearly an encoding or collation issue.
    You mentioned ONE database. What about the other? They should have the same settings in order to have a painless export/import.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Transferred DB to new host, now have ? throughout’ is closed to new replies.