WordPress.org

Support

Support » Plugins and Hacks » myCRED » [Resolved] Transfer shortcode and widget don't seem to be working.

[Resolved] Transfer shortcode and widget don't seem to be working.

  • Hi Gabriel, the transfer shortcode doesn’t seem to be working.

    Using the shortcode of
    [mycred_transfer]
    or
    [mycred_transfer]This text goes inside the wrapper[/mycred_transfer]

    I just keep getting this message: “You do not have enough Points to send.”

    Same thing in a widget.

    Thanks

    http://wordpress.org/extend/plugins/mycred/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gabriel

    @designbymerovingi

    Im on it.

    🙂 You rock!

    Plugin Author Gabriel

    @designbymerovingi

    I assume you are trying to transfer points from an account that has more then 1 point?

    edit – sorry was thinking of wrong add-on.

    Yes, tried with two accounts both with points. Admin and another

    Plugin Author Gabriel

    @designbymerovingi

    Found the issue. I was not strict enough when checking if users can transfer when rendering the shortcode.

    I changed line 645 to: if ( $status === ‘low’ ) { and the same on 656 and it seems to resolve the issue.

    Yep that did the trick. Very cool!

    Thanks

    I still got that issue.
    Frontend transfers give the same error.
    Backend works fine.

    ps.
    I’m just trying this after struggling with cubepoints, and I must say.
    I’m Freaking Impressed with your plugin!
    Great work !

    If it helps…
    I changed the transfer limit from no limit to 10000 per week.
    That seemed to solve the problem for now.

    http://ge.tt/7Ihpyph/v/0?c

    Plugin Author Gabriel

    @designbymerovingi

    Hey hjbarraza

    If you could send me a bug report on our website with login details for your website as a normal user with some points for me to transfer I could do some troubleshooting for you and see what the issue might be.

    Gabriel
    You have an excellent community support!

    It’s on my local machine.
    This weekend I’ll upload the site and share.

    Thanks for showing up and being so passionate.

    Plugin Author Gabriel

    @designbymerovingi

    No worries, Im here to help. Also try enabling WP_DEBUG in your wp-config.php file and see what errors you get or if you are using a local machine you could check your PHP error logs.

    Hi all,

    I’m running into this problem on our site also. I change the daily maximum as was suggested by hjbarraza above, however that doesn’t seem to rectify the problem.

    While I’m not completely comfortable editing .php files, I’m more than willing to give it a shot. What I’m not sure of Gabriel is which .php file I need to change lines 645 and 656. I’m not trying to be thinkc… just new to a lot of this.

    Thanks for the help…

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Transfer shortcode and widget don't seem to be working.’ is closed to new replies.
Skip to toolbar