Support » Plugin: Barclay ePDQ payment gateway for wordpress » transection verification error!

  • Hello!

    I applied the changes on class.epdq.php in line 427 to:

    return array('result' => 'success', 'redirect' => add_query_arg('order',
        $order->id, add_query_arg('key', $order->order_key, $order->get_checkout_payment_url( $on_checkout = true )))
    );

    And also deleted line 49 and replaced with line 435 like this:

    $this->notify_url = str_replace( 'https:', 'http:', add_query_arg( 'wc-api', 'WC_Nom_EPDQ', $order->get_checkout_order_received_url() ) );

    What else am I missing? I setup SHA IN and SHA OUT like I have it in Barclayscards, and I am still getting

    Transection verification error!

    Here’s a sample of an URL generated after the payment has been successfull in EPDQ:

    /checkout/order-received/66980?key=wc_order_5490a0a5f055d&wc-api=WC_Nom_EPDQ&orderID=66980&STATUS=5&PAYID=37873022&NCERROR=0&SHASIGN=CF67CBC94C8ED37B4461C46C99A9F75770AF307E

    Thank you for such a great plugin!

    https://wordpress.org/plugins/woocommerce-epdq-payment-gateway/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same problem here. It processes, but drowns right at the end with that error.

    I solved this by only using alphanumeric SHA passwords i.e. don’t use any symbols. There seems to be some sort of character encoding issue with symbols. Be warned, this makes your SHA keys slightly less secure…

    I’m also having this issue. I haven’t edited the plugin as you have mentioned. Where did you know to make those changes from, and what are they supposed to be fixing?

    Strange thing in my case is that I can get it to fully work on Test but as soon as I switch it over to Live it comes up with this error (I’ve mirrored all settings in the BackOffice).

    It must be something in the way the plugin is creating the digests that’s causing the problem. Any help from the author on this?

    braze

    (@braze)

    Possible fix (worked for me):

    AAVCHECK and CVCCHECK

    In the file class.epdq.php, AAVCHECK and CVCCHECK are all caps, e.g. $_REQUEST(‘AAVCHECK’), however Barclays returns these as AAVCheck and CVCCheck

    Changing the request from all caps to to a mix of the specific way in which the parameters are returned creates the exact same SHASIGN, and bobs your uncle… Order Received.

    At least for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘transection verification error!’ is closed to new replies.