WordPress.org

Forums

YouTube Embed
[resolved] Transcript doesn't work! (11 posts)

  1. immaterial
    Member
    Posted 2 years ago #

    Hi, It tried to embed a video along with its transcript, but this doesn't seem to work at all.

    The code I used was:

    [youtube]complete URL of the video[/youtube]
    [transcript]youtube video ID[/transcript]

    The video is shown in my WordPress post but the transcript is completely ignored (the video has a transcript on youtube however).

    Am I making any mistake or doesn't this command work? Will the transcript be linked to the video and thus advance (highlight and scoll) together?

    Thanks...

    http://wordpress.org/extend/plugins/youtube-embed/

  2. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    Can you give me the ID and I'll check it?

    Also, can you give me a URL of where you've added the transcript shortcode and it's not worked?

    David.

  3. immaterial
    Member
    Posted 2 years ago #

    That's the video ID: XXXXXXXXX
    And here's the link: XXXXXXXXX

    Thanks a lot.

  4. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    I can see the problem - the URL I use assumes the English transcript, which there isn't one for. A bit of an ommision on my part.

    I'll add the option to specify the language in the next release of the plugin.

    If this is the only transcript you're using and want to fix it in the meantime then in the plugin' folder open up the file includes/aye-generate-transcript.code-php and find the line...

    $return = aye_get_file( 'http://video.google.com/timedtext?lang=en&v=' . $id );

    Replace lang=en with whichever language you wish.

    David.

  5. immaterial
    Member
    Posted 2 years ago #

    Hmmmm... I replaced lang=en with lang=de for german but it doesn't seem to work :-/

  6. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    That's probably the cache - the default, I believe, for transcripts is 24 hours. You can adjust this in the YouTube Embed Options screen.

    David.

  7. immaterial
    Member
    Posted 2 years ago #

    Will I have to wait at least 1 hour, then? I tried to empty the cache but it didn't help. Now I set all values to 1 hour...

  8. immaterial
    Member
    Posted 2 years ago #

    Oh I noticed now that putting the transcript cache to zero works! But the transcript is added as text only and isn't interacting with the video. Is this normal?

  9. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, that's all it does. YouTube simply returns the script.

    David.

  10. immaterial
    Member
    Posted 2 years ago #

    Ok! Thanks a lot for helping me! That's great... I wish you a wonderful sunday.

  11. Applian Technologies, Inc.
    Member
    Posted 2 years ago #

    We have now added the ability to specify a language for the transcript in version 3.1

    Applian.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • YouTube Embed
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.