Support » How-To and Troubleshooting » Tranferring Host…error

Tranferring Host…error

  • Parse error: syntax error, unexpected ‘.’ in /home/eliocama/public_html/blog/wp-includes/post.php on line 45

    Receiving this error after moving hosts. To the best of my knowledge I transferred all the files as is and the database correctly.

    Any help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • anyone?

    Upload a fresh copy of that file (wp-includes/post.php) – files get often corrupted during transfers.

    I tried that but with no success. I uploaded the database twice also.

    When it is a file error you should never mess with the database!

    A “fresh copy” means new download, new unzip, new upload via ftp. Files get corrupted via download, unzip, upload etc.

    The tutorial I read said when transferring host I should use all my existing wordpress files.

    I uploaded all my files to the new host.

    Then I uploaded th database and tested received the error.

    I then re-uploaded all the files…tested again…re-uploaded database…tested again.

    Same error.

    We can argue all day long if that’s what you want…
    Please, follow exactly the instructions I gave you above.
    Did you get a fresh copy of that file?
    Yes – No
    Did you upload it?
    Yes – No

    I am not argue and I apologize if you took it that way. I thought you miss understood because said “When it is a file error you should never mess with the database!”

    I was only explaining that uploading the database was a necessity because I was transferring hosts.

    To answer your questions…yes and yes

    Wel,, you do not “upload” the database. You import it or restore it via phpMyadmin. And once it is done – leave it like that. File errrors have nothing to do with the database. So, I know exactly why I said do NOT mess with it. You can do more harm than you think.

    Paste your wp-includes/post.php to http://wordpress.pastebin.ca and post back the url.

    I think I found the problem.

    Thank you for your help…

    So, for the sake of the next poor guy struggling with the same or similar issue – could you post your solution?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Tranferring Host…error’ is closed to new replies.