Support » Plugin: Permalink Manager Lite » Tralingslash removal not working on pagination link to first page

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi @fliespl,

    could you provide me with a sample link where I can check how the pagination HTML output is generated?

    Best regards,
    Maciej

    Plugin Author Maciej Bis

    (@mbis)

    Hi @fliespl,

    I think I got it – happily the issue can be easily fixed this time.

    The below hotfix will be included in the next version of plugin.

    To make my plugin force the “trailing slash” settings to paginate links you will need to add the below line to permalink-manager/includes/core/permalink-manager-core-functions.php file.

    Could you replace the line #20:
    add_filter( 'wpseo_opengraph_url', array($this, 'control_trailing_slashes'), 9);
    with?

    add_filter( 'wpseo_opengraph_url', array($this, 'control_trailing_slashes'), 9);
    add_filter( 'paginate_links', array($this, 'control_trailing_slashes'), 9);

    I can create a sample instance (in a few days), cause current one we are using is restricted to some people only (it’s built for generating static content).

    Basically you need to move blog posts to prefix (like /blog). And create a few items, so that pagination renders. Go to page 2.

    Once you hover over link saying “1”, you will notice it’s using /blog/ even if striping slash is enabled.

    Other pages will have proper urls:
    /page/3 (instead of /page/3/) etc
    only first one is failing.

    Let me know if instructions are okay or I should prepare instance either way.

    @mbis Thanks, I was just pointing out possible improvement – I easily managed to do it. 🙂

    I did in a very similar manner, but using own filter. I didn’t want to break updates to your plugin in the future.

    Best,
    Arek

    Plugin Author Maciej Bis

    (@mbis)

    Thank you, I really appreciate it 😉 I wonder why I have not spotted that issue before.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.