WordPress.org

Forums

trailing slash problem (9 posts)

  1. neonWired
    Member
    Posted 5 years ago #

    I have my blog in a directory and the root page in it's parent. I set it up correctly in settings, most of the links are correct but the RSS feed links add a trailing slash like http://www.mysite.co.uk/discuss.php/?feed=rss2

    Is this a bug or something i havent set up correctly?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Site url?

  3. neonWired
    Member
    Posted 5 years ago #

    its not live

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    In that case, try reviewing http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory and check that you're got WP set up correctly.

  5. neonWired
    Member
    Posted 5 years ago #

    Thanks, that's what i followed to set it up. I think the problem is with step 4 "In the box for Blog address (URL): change the address to the root directory's URL. Example: http://example.com"

    This appears to require that the root be a directory (hence the trailing slash). However the site i'm developing requires that the root is a page which is to have the filename discussions.php (the index page being used for other something else). If i put http://example.com/discussions.php as the blog address setting it seems to take discussions.php as a directory name.

    Is there a way round this other than URL rewriting?

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    It does need to be a folder - not a filename. Set the url initially to http://example.com/wordpress_folder. Then either redirect http://example.com/discussions.php to http://example.com/wordpress_folder. Or have a look at http://codex.wordpress.org/Integrating_Wordpress_with_Your_Website

  7. neonWired
    Member
    Posted 5 years ago #

    If i set the Blog address to the wordpress directory all the RSS links go there which isn't what i want. They need to link to http://example.com/discussions.php

  8. neonWired
    Member
    Posted 5 years ago #

    Is there any edits that can be made to allow a page other than index to be the base.

  9. henkholland
    Member
    Posted 5 years ago #

    Neonwired, I have the same setup as you have and my blog url is:
    http://www.mysite.com without a trailing slash.

    My WordPress url (the one above the blog url) is:
    http://www.mysite.com/wordpress also without trailing slash.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.