Support » Fixing WordPress » trailing dot after url SSL issue

  • Resolved williamsa15

    (@williamsa15)


    Hi all, I have an issue with [ redundant link removed ] where a trailing dot (dot after the URL) is added when clicking from the homepage to any of the other pages on the website.
    This causes the SSL certificate to become insecure and pages to show a warning message.

    Sometimes the page remains secure, even with the dot between the URL and page name, but copying and pasting the page with the dot after the URL shows it as insecure in a private browser or in a direct link via social media or elsewhere.

    The dot isn’t present after the URL in the permalinks settings page so I don’t understand why it’s being added.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • jaynarayan

    (@jaykpatel)

    Thread Starter williamsa15

    (@williamsa15)

    Thanks for this. I have already made sure this is correct and matches what the url should be.

    The website displays the homepage correctly as it is on the settings page but adds the dot when clicking on any other page on the site.

    jaynarayan

    (@jaykpatel)

    Check the permalink settings.

    corusx

    (@corusx)

    the link you have provided works fine without the issue you have mentioned, did you check in other devices ?
    also if permalink settings are fine then maybe you have added a dot while creating menu links mistakenly

    barnez

    (@pidengmor)

    I can also confirm that all the pages accessible by the menu items (main and upper) are loading correctly with no SSL/insecure content errors showing.

    Thread Starter williamsa15

    (@williamsa15)

    Hi everyone, thanks for your help. I realised that all of the urls on the website had been changed to add a dot after the domain name, so I’ve now gone through all hyperlinks on the website that link to pages on the site and deleted the dot from these. It appears to work correctly now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.