Support » Plugin: Better WordPress Recent Comments » Trackbacks showing when configured not to

  • I just updated to this new version, and now Trackbacks are being displayed in my sidebar widget, when it used to only display actual human comments.

    I double-checked the plugin configuration, and to see if any new options were added to the widget, but nothing there seems to have changed, except that comments and trackbacks are being displayed when previously it was only comments.

    Can this be fixed relatively quickly?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Khang Minh


    Hi there,

    Could you please send me some screenshots of your widget settings? In General Options tab do you choose to show Comments only?

    In General Options, I have it to show 5 comments, 0 trackbacks, and the output method is “Do not show trackbacks/pingbacks”. With those options, it was showing the 6 most recent entries, comments & trackbacks together.

    As a test, I changed it to show 10 comments and no trackbacks, and it showed 11 comments, and a trackback.

    I had never set any widget settings before… it was whatever the defaults had been in previous versions.

    I unchecked the “saved settings” box to get to the widget settings again, and changed them to be comments only, but it doesn’t seem to be using those widget settings to override the General Settings, which seems odd.

    I downgraded back to v1.2.0 and all seems fine again, so, something major seems to be broken in the new version.

    Same problem for me. Same plugin configuration, same result. WordPress 3.5.1. My website:

    Ok, I just deleted the widget and created it again, using specific preferences for the new instance. Now I don’t see trackbacks, but I see 6 comments (specific and general options are configured for 5 comments)

    I’m having the same problem. Prior to the most recent upgrade, pingbacks/trackbacks weren’t showing in sidebar. Now they are, in spite of the options being set to block them.

    I’m having the same problem. Just updated, and now trackbacks are showing even though they are set not to. I also have it set to show 4 comments and it’s showing 5. This is breaking my layout!

    Since this never got fixed, I switched to the Decent Comments plugin instead. Problem solved.

    For those of you having this issue, I think I’ve figured it out. Here’s what I did on WordPress 3.6.1.

    • Go to your BWP RC -> Instances section and delete them.
    • Now go to Appearance -> Widgets and expand the BWP box.
    • Clear the instance name and untick “Use saved settings for this instance”
    • Set your required parameters and save.

    That should sort it.

    Jimmeh83’s fix worked for me, but I find the whole thing rather confusing and feel like it is difficult to be sure I’ve saved my preferences. Perhaps the interface for this could be simplified/cleaned up?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Trackbacks showing when configured not to’ is closed to new replies.