Support » Fixing WordPress » Trackbacks broken in 2.0

  • I was using 1.5 and trackbacks worked great. Upgraded to 2.0 two days ago and now my trackbacks don’t work at all.

    When I enter one in the proper field after a post, it just stays there (In 1.5 it would disappear once it had pinged). I even went into the database using phpmyadmin and the url is sitting there in the “to_ping? column. It just doesn’t happen.

    I found this post which suggested some updates to try. I updated both files but no change. I also tried the database “fix? listed and that did nothing. Someone made a patch but I can’t open it with WinZip for some reason.

    Thanks for your help. WordPress is awesome and 2.0 is the best yet.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the exact same problem. The post referred to I also tried but no go. Thanks for WordPress 2.0. Hope this glitch can be solved soon. However I did unzip the files and upload. Nothing seems to have changed.

    When I put the patch file functions-post.php into the wp-includes folder (the other patch doesn’t seem to bother it)… I get the following error. I appears at the top of the blog above the header.

    *** functions-post.php.orig Thu Dec 29 14:35:43 2005 — functions-post.php Thu Dec 29 14:38:39 2005 *************** *** 696,704 **** $post = $wpdb->get_row(“SELECT * FROM $wpdb->posts WHERE ID = $post_id”); $to_ping = get_to_ping($post_id); $pinged = get_pung($post_id); ! if ( empty($to_ping) ) return; if (empty($post->post_excerpt)) $excerpt = apply_filters(‘the_content’, $post->post_content); else — 698,709 —- $post = $wpdb->get_row(“SELECT * FROM $wpdb->posts WHERE ID = $post_id”); $to_ping = get_to_ping($post_id); $pinged = get_pung($post_id); ! if ( empty($to_ping) ) { ! $wpdb->query(“UPDATE $wpdb->posts SET to_ping = ” WHERE ID = ‘$post_id'”); return; + } if (empty($post->post_excerpt)) $excerpt = apply_filters(‘the_content’, $post->post_content); else

    The other patch file in provided in the other thread is execute-pings.php. Supposedly this goes int the wp-admin folder.

    This doesn’t seem to cause trouble… just when I add the dfunctions-post.php in the wp-includes folder.

    Updated: WordPress does manage to ping itself and leave a trackback. Still nothing for other sites. Sits in the to_ping spot.

    Seems you just rename the patch(XXX.diff) to XXX, then put it on. The patched file is used for patching the source. You should put the patch files(with their original name) into the correct dirs and apply the patch by “patch origfile patch”.

    If you don’t know how to patch, you can also download the patched file in the following url:

    Patch for WordPress 2.0 trackback issue

    I used the patched files and it didn’t fix anything.

    Same here. I installed the patch, no change. I tried the “UPDATE wp_posts SET to_ping=”” hint – trackbacks still don’t work.

    any updates on this issue? it’s kind of a major feature for folks to be having problems with and no one in this thread has reported solving the problems with any of the patches.


    Most of the people here describe a problem which leaves the trackback url’s they’re trying to ping in the cue below the posting page (is that correct?).

    I have that issue as well since the upgrade, but what’s confusing me is that some wordpress blogs I’ve pinged take the pings and others don’t. Even more confusing is the fact that some WordPressers who were getting pings previously are no longer receiving them (and I’ve verified it’s not a matter of people not accepting the pings).

    Could this be version-related on both ends? -that’s the only thing I haven’t verified with some of the other wordpressers I’ve tried to ping.

    Anyone else notice this?

    I think this has been fixed in 2.0.1, no? See

    I’ve just posted an article on A solution for this problem….

    Judging from what I’ve seen there may be several different causes for this over wordpress’ existence. I tried the mysql fix (blanking the to_ping entries), that didn’t work… I also have the most current release 2.0.2 as of the moment.

    I have 4 installs running out of one VPS and one of the sites suddenly stopped sending trackbacks. (The one with the most posts…) Basically the solution (in my case) for this (and a blank page after editing/saving a post) was to increase php’s memory_limit directive (default is 8M, I upped it to 32M)… it can be done either in /etc/php.ini for those that can access those files, or possibly in .htaccess by “php_value memory_limit 32M” (Someone else might vouch for that second solution I haven’t tested that one…)

    Basically the tip off was in one discussion thread I saw a user mention that even the execute-pings.php didn’t work for them, they upped the php_value memory_limit to 16M and could at least do execute-pings.php, but not a trackback from a post…
    So instead of upping the memory_limit to 16, I tried 32M and everything works – trackbacks – no blank page after posting…

    I hope that helps someone out.

    I couldn’t find a etc/php.ini file, so I added that line to my .htaccess. Now I’m able to leave a pingback to a blog I wasn’t able to before. I’m still waiting to hear if the trackback worked, but I wanted to say thanks!

    Rosie, dumb question time. Where is the .htaccess file located in your setup? In the WordPress directory? Or a parent directory? I have no success with .htaccess in the WordPress directory.

    The .htaccess file I edited is located on the same level as my WordPress folders and files, so I guess that’s called the parent directory?

    The lineup looks like this:


    … and then all the other WP files follow.

    Okay, I thought so. I have two WordPress installs on my computer, so I’m going to attempt to modify the php.ini file first. (Now that I’m in the office, I have full access to the server.) If that doesn’t work, I’ll create and modify the .htaccess files in each WordPress folder.

    Thanks for your help.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Trackbacks broken in 2.0’ is closed to new replies.