Support » Fixing WordPress » Trackback/Pingback URLs fail 404

  • Using WordPress 1.0.1
    Trackback/Pingback URLs fail with a hard 404 error, which implicates the RewriteRules (or rather the lack thereof) in the .htaccess file, which only contains:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([0-9a-z-]+)?/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^archives/category/?(.*) /index.php?category_name=$1 [QSA]
    Can anyone supply the RewriteRules that _should_ be in there so I can get this running?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Windows, or Linux?
    IIS or Apache?
    I know there are issues with mod_rewrite being used on Windows systems, that’s why I ask.
    Even if it’s not a Windows machine, it is possible that mod_rewrite could be turned off. Check with your web host.
    TG

    You nay need to turn path info processing on for wp-trackback.php. Try this in .htaccess.
    <Files “wp-trackback.php”>
    AcceptPathInfo On
    </Files>

    I have the same problems and tested the additional lines (AcceptPathInfo On etc.) in my .htaccess. The result was an error 500 (Internal Server error) for my whole website (www.r-craven.de). The problem disappeared after I deleted the <Files> … </Files> part from the .htaccess.
    Are there any other solutions?

    Thread Starter lofcom

    (@lofcom)

    > You nay need to turn path info processing on for wp-trackback.php
    Worked like a charm; much thanks for the info! Hum…time for me to hit apache.org and study up on AcceptPathInfo.
    (My goal is to, once everything’s set up and working correctly, to drop the .htaccess data directly into httpd.conf to save the cycles.)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Trackback/Pingback URLs fail 404’ is closed to new replies.