Support » How-To and Troubleshooting » trackback to myself

trackback to myself

  • Anyone noticed if you link to one of your own posts it tracksback to itself. Kind of annoying to have to delete them from the original post.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Unless you’re trackbacking any other links in that post, you can uncheck the ‘Send Trackbacks to all URI’s in the post’ option on the advanced editing screen.

    Important to note that you are not sending trackbacks with links in a post, but pingbacks. A small but important difference.

    Also, to avoid “pinging” your own blog posts, use relative links:



    Does not ping:


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘trackback to myself’ is closed to new replies.