Trackback pinging broken? (9 posts)

  1. Anonymous
    Posted 11 years ago #

    Hi folks,
    I was wondering if TrackBack pings were broken for URLs that POST to a URL with a query string? I looked at the code and saw this:
    $http_request = 'POST ' . $trackback_url['path'] . $trackback_url['query'] . " HTTP/1.0\r\n";
    I think it should be this:
    $http_request = 'POST ' . $trackback_url['path'] . "?" . $trackback_url['query'] . " HTTP/1.0\r\n";
    note the addition of "?" .
    I was wondering if this was an intentional omission or if this was a bug? I haven't checked CVS yet to see if it's been fixed.

  2. ccheaton
    Posted 11 years ago #

    Trackbacks have never worked on my WP blog.

  3. nachoman
    Posted 11 years ago #

    They work for me for TB urls that use extra path info like WordPress... instead of a combination of Query String and POST data like something I'm testing. Other apps work fine with this, btw.

  4. ccheaton
    Posted 11 years ago #

    WP 1.2. I've never really cared, but they've never worked. *shrug*

  5. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Try updating to v1.2.1.

  6. debwire
    Posted 11 years ago #

    They don't work in 1.2.1 either.

  7. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Do you have an xmlrpc.php file in your blog directory?

  8. Beel
    Posted 11 years ago #

    "they don't work" continues to be disingenuous at best. They do work just fine on many sites - sorry they don't work on your site. Instead of posting misleading statements (which won't bring you closer to solving your problem) you could join in the search for an answer.
    Sujal, I hope you get an answer to your question. If you do elsewhere, please post back here. I haven't heard of such a problem but I will keep an eye for an answer.

  9. ajparker
    Posted 10 years ago #

    It may be a php memory_limit issue - that was the case for me. Trackbacks "suddenly" stopped working at one point, I tried every suggestion I could find and then upped the /etc/php.ini memory_limit to 32M (.htaccess can be used as well php_value memory_limit=16M )....

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.