Support » Plugin: teachPress » TP 6.2 needs php 5.4 breaks with php 5.3

  • Resolved sopko


    This plugin is great, I updated to 6.1 when it came out. I updated a test site to 6.2 and it broke because we run Redhat 6.9 which keeps its php version at 5.3 and does security fixes. Not that easy for me to upgrade to another OS for our website.

    The core WordPress requires php 5.2 or later. The error in the apache log was:

    PHP Parse error: syntax error, unexpected ‘[‘ in /var/www/cdn/wp-content/plugins/teachpress/core/templates.php on line 475

    php 5.3 does not support the array syntax that was used on line 475 need php 5.4 or higher. I fixed like this:

    /* $url_displayed = []; */
    $url_displayed = array ();

    I don’t know if there are any other things in TP that need php 5.4 or higher.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author winkm89


    Hi sopko,

    Thanks for reporting this problem. It should fixes now with the version 6.2.1 of teachPress.

    Thread Starter sopko


    Thanks! I know it is a pain for developers to be stuck with php 5.2. We run Red Hat 6 servers that stay at php 5.3 and not that easy to move to a newer OS. Great plugin!

    Plugin Author winkm89


    And it seems you are not the only one, who had troubles with upgrading servers. I had a lot of requests about that problem on GitHub and by email. I think it was a new record for a single bug in the plugin. Luckily it was just a single line. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘TP 6.2 needs php 5.4 breaks with php 5.3’ is closed to new replies.