Support » Fixing WordPress » TotalCache & CDN: 10 Sec Load on 800KB?

  • Resolved fuzzyfluid

    (@fuzzyfluid)


    Hey there, I’ve developed a few wordpress sites, however, I’m having trouble with general load times. I don’t care much for pingdom/gtmetrix/google page speed scoring, however, the scoring is fairly high across all the sites.

    The issue is im getting close to 9.5 seconds on ~760kb which i think is extremely long. Any advice on wha I missed?

    I’m using Autoptimize for minification. w3 total cache, cloudflare (previously tried jetpack site accelerator which yielded similar results), and EWWW Image Optimzer which did a good job on shrinking overall image size(previously had Smush which also yielded comparable results, butt went with EWWW for the free webp conversion.)

    Any help much appreciated,

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Page is loading for me in an average of 2.56 seconds or so. Tested with Pingdom and it took like 1.39 seconds.

    First loading: 11 seconds.

    Second loadings, in any browser including the one that got the eleven seconds: half a second.

    Maybe some parts of your hosting are experiencing occasional bottlenecks, that happen here and then, but not every time?

    Otherwise, if both w3 total cache and cloudflare are active and ready to serve static files instead of the default PHP generated every time, that means, anyway, that it’s your hosting that takes a break for a smoke and checking the news, before it remembers there are visitors waiting for the site to load. The first reply, the http loadtime, is the concern, I’d guess.

    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    hmm, should i ignore pingdom and gtmetrix loading times? I’m concerned it’s an issue with scripts or plugins. The test you did was leveraging Jetpack Site Accelerator. I’ll switch to the CDN and confirm and reply back –

    Thanks for checking, still the initial loadtime concerns me.

    webpagestest from Virginia on cable bandwidth says 1.764s (onLoad)/ 2s fully loaded, but there does seem to be a problem with images not loading.

    additionally; you seem to have “inline & defer” on in Autoptimize but have not set the “above the fold CSS”, leading to that big flash of unstyled content. see the AO FAQ for info on how to get “that above the fold CSS” just right 🙂

    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    i’ve moved it over to cloudflare and fixed he images not loading. I removed imaages to see if that would improve load time. This is after having tested mediatemple’s grid server for all content and after testing jetpack site accelerator with the same results.

    Thanks @optimizingmatters i’ll check the automptimize.

    Can anyone confirm the load time delay?

    Can anyone confirm the load time delay?

    First load today: 12 seconds.
    Every followup load in every browser: instantaneous ¯\_(ツ)_/¯

    Curious, how does going to https://flashbackchamps.com/ first vs http://www.flashbackchamps.com/ compare? The later redirects to the former. Since it redirects, I would be linking to https://flashbackchamps.com/ anyway.

    • This reply was modified 1 year, 5 months ago by MarkRH.

    Ah, that must be it, Mark.

    Attempting the non-https gave me 5-6 seconds delays, indeed. If it’s already abnormally long, it may be even longer on the occasion.

    https://imgur.com/a/pOQXsVX

    • This reply was modified 1 year, 5 months ago by Sabinooo.
    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    Typically https is slightly slower than http due to the encryption. Are you guys saying the https loads significantly faster than the http? Could it be an issue with Real Simple SSL plugin?

    Typically https is slightly slower than http due to the encryption.

    Only for the secure connection setup, after that https (http/2) makes up for that with concurrent (‘multiplexed’) downloads of resources, which doesn’t happen on http.

    new test on webpagetest (5 test runs); mean load time of 1.7s, fully loaded at 2.9s. best run 1.5s, worst 7.5s. still occasional 404 on images?

    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    hey there, just to close out: I have the SSL certificate on my host, mediatemple. Mediatemple nameservers changed to CloudFlare. Does cloudflare by dedault have SSL turned on? Is it possible the two SSLs is what’s causing the slowdown?

    SSL configuration with Cloudflare may be confusing because of the multiple options they offer, made to accomodate several possible situations.
    (1) They’ll attempt to do good by offering SSL when there is none available (they call it “Flexible”), but they’ll also have
    (2) the option to accept a self-signed certificate on the server (the server secures the communication between you and it, but it’s not certified by any web authority: guaranteed alert in the browser of the visitors) while “converting” it to a globally recognized certificate (no more alert in the browsers of the visitors) (they call it “Full”) , and of course there’s the final option to
    (3) simply take the fully valid SSL of the website and just pass it along to the rest of the internet without any complications (they call it “Full (Strict)”). This third situation is the most common one, as normally your host provides you with a valid SSL solution.

    I don’t know which is the default config for Cloudflare regarding SSL.
    However, I would be inclined to doubt there’s a relationship with your problem, normally it’s a matter of a minuscule fraction of seconds at the beginning of the connexion.

    Regarding the nameservers changed to Cloudflare: this is fully normal, and fully necessary. If you want Cloudflare to stand between the world and your server, so that it may deliver cached contents, the nameservers must be pointed to Cloudflare. This way, the rest of the world is asked to call Cloudflare instead of calling your server.
    This bit shouldn’t cause any delay at all, none.

    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    I checked and on cloudflare i have set :Full (Encrypts end-to-end, using a self signed certificate on the server).

    Some additional Settings:
    SSL: Flexible (Just changed this now)
    Always USE Https: On

    Http Strict Transport Security (HSTS)
    Status: on
    Max-Age:0
    Include subdomains:0
    Preload:0

    Opportunistic Encryption: On
    TLS 1.3: On
    Automatic Http Rewrites: On

    I do believe the HTTPs is causing the slowdown. Lazy Loading enabled and confirmed, cloudflare for CDN, autooptimize on css/js. Such a shame, anny additioanl insihgts?

    • This reply was modified 1 year, 5 months ago by fuzzyfluid.
    • This reply was modified 1 year, 5 months ago by fuzzyfluid.

    At this point, I feel this is something you should instead ask of your web host and to Cloudflare, through their own respective support ticket systems.

    But it’s super hard to tell, no idea why or how it works, I only get one or two slowdowns each time, after which it works fast again, so good luck testing when it’s hard to replicate an issue on demand.
    What I would do myself, for further testing, is to check if wordpress can be blamed or not, then if the server’s innards can be blamed or not.
    Take any media image on your site, copy its URL location, test it in your browser, does it have the same slowdown or not. (But again, maybe the slowdown won’t happen again and yet it’s here that there is the problem.)
    If yes, same slowdown: no PHP was required for the loading of the image, so it’s officially not wordpress’ fault.
    If not, quick loading this time: that might have to do with PHP in your server, wordpress or the server itself, or the SSL with cloudflare.

    Sorry, I can’t help!

    Thread Starter fuzzyfluid

    (@fuzzyfluid)

    Thanks f or the response sabinooo. I’ll solve and follow up for those who may be having the same issue. If anyone else has any ideas, please let me know,

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘TotalCache & CDN: 10 Sec Load on 800KB?’ is closed to new replies.