Support » Plugin: W3 Total Cache » Total Cache Image Service doesn’t work on my end

  • Resolved zzlatevv

    (@zzlatevv)


    Hey guys,

    First, I want to thank you for the great plug-in, it’s really helpful.

    Can you please help me with something? The Total Cache Image Service seems doesn’t work on my end – it still says “processing”. I checked on Google PageSpeed and it still says that I have to use the WebP format. Please check the screenshot below.

    https://www.screenpresso.com/=DrR3c

    Thanks in advance!

    P.S I’m using a staging site on tastewp.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @zzlatevv

    Thank you for reaching out and I am happy to assist you with this.
    If it still says Processing... it means that the conversion is still not completed.
    We are working on adding more resources to this and, please understand that once the update was released there were more than 300k requests.
    It should look like something like this once it’s completed:

    Thank you for your patience.

    donlee101

    (@donlee101)

    Hi. We have some images completed. But when i check developer/network images are still jpeg and in original size. In the upload folder via ftp i can see actual converted images in webp. But in frontend wordpress is not serving them.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @donlee101

    Thank you for your feedback.
    have you tried purging the cache once the conversion of the images was completed?
    Thanks!

    donlee101

    (@donlee101)

    Hi sir, yes i did. It’s not fully completed. About 1000 images and 2200 left. It’s going pretty fast for me. I did forget to update nginx rewrite rules. So i did, but made no difference in frontend, webp still not being served anywhere.

    https://imgur.com/a/0UXHhou

    Link to product for you to check pls: https://www.balnecroftcountry.co.uk/hoggs-of-fife-albany-ladies-lambswool-waistcoat/

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @donlee101

    Thank you for the information.
    I can see indeed that the images are converted:
    https://www.balnecroftcountry.co.uk/wp-content/uploads/2021/11/Higgs-head-band-350×438.webp
    can you try disabling the Browser Cache, save all settings and purge the cache and see if the status is changed as there is a possibility that cached images are showing in the browser?
    Thanks!

    I have tried disabling browser cache and purging everything and still does not work. There are some new product images which have been converted on upload and they’re not being served as webp either. So don’t believe it’s caching issue :/

    is the nginx rewrite rule correct?
    location ~* ^(?<path>.+)\.(jpe?g|png|gif)$ {
    if ( $http_accept !~* “webp|\*/\*” ) {
    break;
    }

    expires 31536000s;
    etag on;
    if_modified_since exact;
    add_header Pragma “public”;
    add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
    add_header X-Frame-Options “SAMEORIGIN”;
    add_header Vary Accept;
    try_files ${path}.webp $uri /index.php?$args;
    }

    try_files $uri $uri/ /index.php?$args;`

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @donlee101

    There could be something that is making Nginx not test the location that we added.
    Potentially some usage can mess with things. See https://www.nginx.com/resources/wiki/start/topics/depth/ifisevil/
    You can try adding debug to the error_log directive in the nginx.conf file, it will show you what locations were tested and what patterns used. Some things may cause the location to be skipped.
    Of course, if you have a busy site, then you should test it on another site or enable debug for a short time.
    I hope this helps!

    Hi,

    i got it working 🙂

    For those using PLESK and nginx caching with proxy mode.
    I had to remove image extensions (jpg,jpeg,webp,png) from “serve static files directly by nginx” then use w3 total cache nginx rewrite rules in additional nginx directive
    Now my webp images are happily being served.
    https://imgur.com/a/E9s2Vhh

    Thanks for your help.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @donlee101

    Thank you very much for this useful information.
    Glad to know the issue is resolved.
    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.