Support » Plugin: Complianz | GDPR Cookie Consent » Topic 3 isn’t being tranlated (Loco)

  • Resolved OKEIwebbureau

    (@twolle)


    Hi,

    Topic 3 isn’t being tranlated (I am using Loco translate).

    https://pressemeddelelse.dk/cookie-og-persondatapolitik/

    3 Hvad er scripts? / What are scripts?
    A script is a piece of program code that is used to make our website function properly and interactively. This code is executed on our server or on your device.

    Hope you will fix it ๐Ÿ™‚

    /OKEIwebbureau

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @twolle,

    Thanks for reporting your issue.

    I think the .pot file needs to be synced. You can do this in Loco Translate, by going to the languages overview.

    Then you click “edit template”, “sync”. Then save.

    After that, you go to your language, click “sync”, and save. The untranslated line will appear, and you can translate it.

    I will update the .pot file in the plugin as well (for the next release). You can als upload your translations to https://translate.wordpress.org/projects/wp-plugins/complianz-gdpr/dev/da/default/, by using the “import” option at the bottom. This way the community can profit from your translations, and others can help maintain it.

    Let me know if you have any questions!

    Thanks – it worked ๐Ÿ™‚

    However I still have some problems:

    1) To the right for the button “Revoke cookie consent” I have (in danish): Aktuel status: AccepteretAktuel status: Afvist.

    It says that the actuel state is both accepted and denied ???

    2) Topic 8 Placed cookies. It is not possible to translate everything…

    Google Analytics
    Formรฅl: Performance
    Tilbageholdelsesperiode: From session up to two years
    Beskrivelse: We use Google Analytics, a web analytics service provided by Google. Google Analytics uses cookies that allows us to analyze the use of our website and to compile reports on website activity and internet usage.

    Thanks for helping.

    /Twolle

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    For the first issue: you have probably disabled the custom document CSS in the settings? Because of this, the default css, which hides these notices, is not there.

    You can choose to either set them to display:none with some custom CSS, or enable the document CSS.

    The second: we’ve recently discovered that loco translate skips some translatable strings. I have created a new .pot file, which will be included in the next release, that should resolve this.

    Because Loco Translate skips the lines, syncing won’t help in this case. But it will be resolved soon.

    In a few weeks, with the cookiedatabase.org update, all cookie descriptions will be managed in multiple languages by the community on cookiedatabase.org, and synchronized with the API. When that version is released, maintenance will become much easier!

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    I’ve updated git with a complete .pot file:
    https://github.com/rlankhorst/complianz-gdpr/tree/master/languages

    You can use it to sync your Danish file with, enabling you to translate these strings.

    Thank you for the info ๐Ÿ™‚

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    hi @twolle,

    The latest update contains an updated .pot file.

    Great, thanks ๐Ÿ™‚

    Looking forward to having it all included in the .pot file.

    /Twolle

    My website gives a few errors. It worked before but I updated some plugins and I only updated WordPress to 5.3 and changed the current theme to another theme. The site was deprecated thatโ€™s why I needed to update everything. But now I get this error. Does someone has a solution. Maybe some kind of a roll back I can do. I can acces FTP.

    My website: http://hanzstoffers.nl

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    The issue is not related to Complianz, you have a plugin “theme_support_craig” which depends on a function which isn’t there.

    If you go to your site with FTP, then rename the plugin theme_support_craig to theme_support_craig_backup, the plugin is disabled, and the error should be gone.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.