WordPress.org

Forums

WassUp Real Time Analytics
[resolved] Top Stats Link issue (11 posts)

  1. Headroom
    Member
    Posted 1 year ago #

    We're runnin version 1.8.4 of the phantastic Wassup plugin with WP version 3.8.1.
    Unfortunately the 'show top stats' link under the Wassup Stats tab in the admin dashboard section doesn't work here. If clicked the window dims down to dark grey and a progress bar comes up for about a second and that's it. With the next click the page returns to initial state.

    Probably someone knows a solution.
    TIA.

    https://wordpress.org/plugins/wassup/

  2. michelem
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    can you try to deactivate other plugins and run only WassUp? (Akismet and default plugin can stay active).
    Thanks

  3. Headroom
    Member
    Posted 1 year ago #

    Hi,

    did so but no difference.
    But clicking the 'Show Top Stats' link leads to the following error in the browser console - [Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (action.php, line 0)http://www........../wp-content/plugins/wassup/lib/action.php?action=topten&from_date=1396204200&to_date=1396290730&whash=47bda80662ef76d2407c8462ac39956d&width=870&height=440&random=1396283538653

    Any idea?

    TIA

  4. helened
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hmm...the last query parameter "&random=1396283538653" shouldn't be there. Another application or plugin must have added that to the URL.

    Try click "Show Top Stats" again, then copy the top ten URL from your browser console directly into your browser location field with/without the "random" parameter and let us know what happens. Thanks.

    Helene.

  5. Headroom
    Member
    Posted 1 year ago #

    Hi,

    unfortunately nothing new. Whatever version I've copied into the new browser windows url field the result is an empty white page. The error msg in the console remains the same.
    In the meantime I've tried to upgrade to the newest jquery.js version (1.11.0) but this makes no difference too. Hm.....

  6. Headroom
    Member
    Posted 1 year ago #

    Ok - WP File Monitor v. 2.3.3 prevents the hover window from opening. Is fixed.
    But we still can't see any contents in the window. Means no stats.

  7. helened
    Member
    Plugin Contributor

    Posted 1 year ago #

    Your host server may be blocking the top ten URL from running. Try entering the top ten URL with NO parameters (http://www ........../wp-content/plugins/wassup/lib/action.php) in a new window/tab.

    If the script runs, you should see an error message in the browser window. Then try the URL with the 1st parameter (http://www ........../wp-content/plugins/wassup/lib/action.php?action=topten), then with the 1st and 2nd parameters, and so on, until you find the parameter that triggers a blank page and 500 error in your console.

  8. Headroom
    Member
    Posted 1 year ago #

    So up to the 'to-date' param included we've received a 'Missing or invalid parameter - Permission Denied!' msg. From that on - next was the 'whash' param - we got the already known
    '[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (action.php, line 0)' msg.

  9. helened
    Member
    Plugin Contributor

    Posted 1 year ago #

    UR awesome!
    I'm close to pinpointing the problem, but there yet. One possibility is that your host server treats 'whash' is a special request that interferes with the URL.

    Try test this by adding the top ten 'whash' parameter to a couple URLs that you know works on your site. Ex:
    in WordPress: www. ...../wp-admin/plugins.php?whash=....
    with an image: www. ...../photos/mypicture.png?whash=....

    Also, try a couple more tests like above, but with a different value for 'whash' (like whash=123456abcdef), in case the value of 'whash' is the problem, not 'whash' parameter name.

  10. Headroom
    Member
    Posted 1 year ago #

    Finally - shame on us - the abspath param in the wp-config.php was wrong.
    Therefore the click on 'Show Top Stats' made the action.php file fell on its nose in line 58. Thus, the error message - [Error] Failed to load resource - was correct.
    Anything else - whash param, loggedInUser check aslt.. was/is in absolutely proper condition.

    Thanks for your dedicated help!

  11. helened
    Member
    Plugin Contributor

    Posted 1 year ago #

    Glad that you were able to find and fix the problem.

    Thanks for using WassUp!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WassUp Real Time Analytics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic