Support » Plugin: Multiple Domain Mapping on Single Site » Top page doesnt work but sub pages do

  • Resolved betterbizworks

    (@betterbizworks)


    Hello. I set up the redirects so that when you click on the holiday shop page it’s supposed to change to the url I included. All of the sub pages switch to that url fine but the plain url and parent page redirect to the home page.

    Im also trying to make eventsbyfunservices.com point to our fun-fairs page and that redirects to the home page as well.

    Picture of my redirect settings

    Im using Plesk on an ubuntu 18.04 server. All domains have SSL.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • I’ve run into this problem too. It’s always worked for me before. After studying the setup instructions now I’m wondering if it’s because I set up the domain mapping settings before actually pointing the domains to the wordpress app itself. And if that is the problem I’m wondering how to fix it.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    hy.

    i can’t see any issue on the site of @betterbizworks. if you have already resolved the issue, please report back here to help other users like @munchmonster 🙂

    sometimes this has to do with caching plugins. that’s a big topic where we can not give any hint on which caching plugin to use so far :/

    matt

    Plugin Author matthias.wagner

    (@matthiaswagner)

    hy,
    we have just updated our faq section after successfully testing it with W3 Total Cache. if caching was the reason for your – please stick to that faq 😉

    I am still having the issue. I don’t have any caching enabled for this site either. This site is different to my others in that the main site domain is a subdomain. I can’t think what else is different though. Child pages of mapped domain pages work, but the top mapped page itself just redirects to the home page.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    hy,
    the subdomain-setup is tested too, that should not make any problems.
    are you 100% sure that the redirection is not stored in your local browser cache and that no other plugins or code snippets (maybe in htaccess) cause the redirection?

    the setup in the „wrong“ order is no problem, btw. we just encourage to do it in this order to see if external setup is working before dealing with possible plugin issues …

    you can also provide a link to your site, otherwise i don’t know how to provide further help. we do not work with private mails, login credentials, …

    matt

    I don’t think it’s part of my browser cache because it happens on other devices and in private browsing mode too. I do have a code snippet in the header of each mapped page to give the pages a unique favicon, that script is:

    <link rel=”icon” href=”THE PNG URL” />

    But this works fine in my other sites with domain mapping too.

    I’ve sent you an email to the address on your website with the website addresses I am dealing with here.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    so when you say “it always worked before” – what did you change? any plugin/theme-updates? what time was “before”? 😉

    since this looks like a test page, please also add a wordpress menu where those pages are included, to see if our plugin correctly changes the permalinks inside

    Sorry I should have cleared up what I meant by before. I have made two other sites with a lot of mapped domains and by before I mean both of those sites, which have always worked as expected. I just made a third such site and this third one is the one giving me problems.

    I have updated that child page I sent you with some content and I think I see what you mean. On my two other sites where this is all working as expected, all the old URL paths are changed to the mapped one. If you right click and view an image the URL path matches the mapped domain. However on the third site I am having problems with, even though the child page appears the image URL isn’t changed. And links aren’t changed either. I noticed in the past it seems like all instances of the old URL are changed for all media, which is what causes the Lottie animation functionality of Elementor Pro need CORS enabled (or Lottie files hosted on a different uninvolved domain).

    I have updated the child link I sent you to include some links, a menu, and an image.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    could you try to enable this plugin https://wordpress.org/plugins/disable-url-autocorrect-guessing/. since the redirection is done by wordpress and you are sure that you do not have any redirections enabled, it could be that the wordpress url-guessing makes the difference here…

    of course, again watch out to have browser cache disabled 🙂

    if that wont’t make a difference, please install this plugin so that the redirection can be debugged easier: https://github.com/stracker-phil/wp-debug-redirect

    matt

    Disable URL Autocorrect Guessing didn’t change anything for me. I added WP Debug Redirect and I can see the Headers information in the developer tools. I don’t really know how to interpret the wpdev-redirect-traces though.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    i see!
    you can try to add a return:false; in our plugin “multidomainmapping.php” – file in line 506 as seen on this screenshot: https://ibb.co/nfsRtHH

    will this make any difference?

    I’ve added return false; like in the screenshot and that doesn’t seem to change anything. return:false; with the colon breaks the site though.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    the colon was my fault 😉
    that’s very weird.

    one last thing we can try is that you change the original permalink slug from your top-page to something that sounds completely different than your mapped domain. i have the doubt that the wordpress redirect-guesses have something to do with the problems here and that would be another try to get around this. but it would be more like a lucky punch 😀

    otherwise i don’t see any chance how we can debug that further. you will understand that we are not plugin-developers in our main business and have very busy times around here, so it is not possible to dive deeper into this :/

    matt

    > change the original permalink slug from your top-page to something that sounds completely different than your mapped domain

    That was one of the first things I tried actually.

    I’ll keep playing around and see if I can figure it out. This site with problems is native nginx, but I’ve used your domain mapping plugin with another site that is native nginx without issue.

    If you ever make a premium version of this plugin I think I would purchase it.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    thank you for your understanding and good luck!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Top page doesnt work but sub pages do’ is closed to new replies.