Support » Fixing WordPress » top-nav always visible after adding SSL

  • Hi and hello,

    I today was able to activate the lets encrypt cert option offered by my hoster and to switch to https by using one of the wp-plugins for the migrations.

    I have a secured connection, graphics are shipped with a https path and I can login after having the admin-ajax.php issues.

    However – and what I not can fix – is the state of the art that the ‘top-nav’ bar .. the black bar with the ‘Click to Add your menu’ link is presented to me – I am not logged in .. cache cleaned IE / FF / Chrome .. the bar is visible if I attend my start page (so no logged in user). AND if I have my Huawei smartphones chrome – the bar is not visible at all! As mentioned cache cleaned desktop browsers.

    What can / what must I do .. the bar indicates me that i am in a logged in state..
    even if pressing the link leads the visitor to the regular login page.

    Any ideas or reasons for that behavior?

    Thanks and with best regards,
    Stefan

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey Stefan,

    Are you using a caching-plugin? Maybe you can avoid this behaviour, if you turn off any caching-plugins, and browse to your site in a private window.

    Best regards,
    Brian

    • This reply was modified 2 years, 7 months ago by Ixium.

    Already turned this plug off.

    The error direct occurs if switching between http and https using my hosters liveconfig.

    It could be possible, that not all off your links within WordPress are changed. Since, not all plugins will do the job correctly. I noticed that a plugin like better search replace does the job incredibly good. You can change http://yourdomain to https://yourdomain by doing an automated search thorough the database en let it replace everything.

    replaced 39 chunks (thx) – still the bar on top

    /:

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘top-nav always visible after adding SSL’ is closed to new replies.