Support » Plugins and Hacks » [Resolved] top menu and search not working

[Resolved] top menu and search not working

  • This is a bit of a long shot but the plugin works well for me and seems like the support community are pretty knowledgeable, so here goes…

    I have WPTouch working ok on http://www.isthismusic.com – apart from the problem that the menu and the search in the top bar don’t work (the menu ‘responds’ to a touch but there’s no dropdown).
    I actually tried disabling all 30 of my plugins, and, you guessed it, the menu and search operate ok!
    But I was hoping that someone here might have an idea of any conflicts before I start on what might be quite a task in locating the bad plugin (plus, they’re all pretty essential for the site’s operation).
    I already tried the suggestion elsewhere or going onto Advance mode and “Use jQuery 2.0 in themes” but it didn’t help.
    Any ideas that’ll save a lazy site admin (with not that much tech knowledge) wading through the plugin list?



Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi smchugh,
    try to refresh your page and clear your browser cache.
    The “Use jQuery 2.0 in themes” technique works fine.


    Hi Andrea
    unfortunately that didn’t make any difference – cleared the cache data but the menu still doesn’t work. Must be one of these darn plugins – but which one…?


    Plugin Author BraveNewCode Inc.


    Try enabling Advanced Settings in Core Settings— and then check the box to use jQuery 2.0 in themes.

    The issue is caused by other plugins or themes loading al older version of jQuery— WPtouch Pro requires at least jQuery 1.8, and some plugins and themes force load an older version of jQuery.

    Having same problem also tried enabling jQuery 2.0 .


    Please help

    Meant to get back as I sorted this a few days ago by the tried and tested method of disabling every plugin in sequence (!) – it turned out that by taking out the Last.fm covers plugin it resolved itself and my menus are ok on the mobile now (I do find it sometimes tries to load the web version occasionally for some reason though).

    Guessing this is a bit of a long shot for you, but it could be a conflict with something else. I find that disabling the first 15 of my 30 plugins, then the second half, is the way to go (then, the first quarter, 7 or so; then the second 7… and so on…)

    Any other method……

    not from me or I would have used it! I’m no expert anyway, I suppose looking at the older plugins first, that would be most likely to fail. Or the ones you don’t need quite so much or could replace easily with something similar. Or any that look like they’d use jQuery or whatever it is that drives the menu popup.

    Thank you for your reply
    developers please help…..

    Plugin Author BraveNewCode Inc.


    The reason for this issue is usually another plugin or the desktop theme force loading an older version of jQuery (usually jQuery 1.6 or older).

    WPtouch relies on at least jQuery 1.7, released in August of 2012. Since those plugins or themes are force loading a specific version of jQuery, and WPtouch has jQuery code dependent on a newer version of jQuery, WPtouch’s JavaScript code fails.

    The “Enable jQuery 2.0” Advanced setting in WPtouch works to solve this issue by replacing the older version with a newer one.

    We think all plugins and themes should work with the version of jQuery that WordPress itself ships with. There are numerous articles about why you shouldn’t do this, and that’s why we make the Enable jQuery 2.0 setting an advanced one that’s off by default.

    On December 11th 2012 WordPress released version 3.5, which included jQuery 1.8.3. It’s this version that WPtouch relies upon, and I think its reasonable that we depend upon it, since we officially state we support WordPress 3.6 or newer.

    I was having this same problem and the suggestion to enable Advanced Settings in Core Settings— and then check the box to use jQuery 2.0 in themes worked for me.

    argh, I thought this was all sorted even though the web version didn’t work too well – but then I discovered the web version was showing mobile pages! Had checked the jQuery box and done all the cache setting stuff. Also, the toggle buttons don’t show up, so I can’t force it to test it. Infuriating as everyone else seems to be getting along just fine, and it seems to be the best (only?) solution.

    Hi, I have the same problem. I have already checked jQuery 2.0 box, still menu button doesn’t work…


    I have got different two problems, will describe it in next thread…

    Thank you, @bravenewcode Inc!! Your answer fixed my problem.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] top menu and search not working’ is closed to new replies.