Support » Fixing WordPress » Top Banner on Home Page Has Disappeared

  • Resolved will-s

    (@will-s)


    Hi,

    My client’s longtime blog site has suddenly lost its home page title banner, and I’ve made no changes. See big blank space at top of the page cited above.

    Sometimes when the page first opens, you can see a flitting ghost of the banner type for a second. And, if you hunt around, you can actually get a cursor to highlight the type and show it clearly and steadily. It says “Freddie Gershon / The Blog,” on two lines, but the colored background is still missing. Problem happens in Firefox, Safari, and Chrome. I’m on an iMac, running OS Mojave, 10.14.6. I’ve updated plugins, themes and WP.

    Everything else seems to work fine. And I built my client a similar wordpress blog, with a similar title banner and that banner is visible. See: https://sherpspace.com/wordpress/

    Any help, etc. Thanks.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • The code below got added to your Customizer .css area or something similar in the theme.
    There is no link to an image and will not work.

    #header {
    background: url(https://freddiegershon.com/freddiesblog/wp-content/themes/default/images/header-img.php?upper=000000&lower=00FFFF) no-repeat bottom center;
    }

    The image is there but the above code is overriding the correct code which is still in your style sheet.
    https://freddiegershon.com/freddiesblog/wp-content/themes/default/images/kubrickheader.jpg

    Thanks, Kim, for this heads up.

    In the Inspector section of Inspect Element, I found the offending code you said is overriding my image. But it is commented out.

    And I did a word-search for it among my files and couldn’t find it. The closest I got was this: $output .= “#header { background: url(‘$url’) no-repeat bottom center; } which was in the functions.php file in the default theme folder.

    I also went into a folder called Customize and looked at the phps there with words like “background-image-setting” and “customize-image-control” in their names but couldn’t find it there either.

    Can you tell me where you found it? Or whether it might be irrelevant because it’s commented out? Or what I should try next?

    Thanks!

    I’m sorry, I did not get your notification that you had answered.

    Yes, I think you are right “#header { background: url(‘$url’) no-repeat bottom center; } is creating it…

    Since your theme is rather old I am not sure how it works with the customizer.
    Is there a setting for you to use “CUstomize” under the Appearance tab? If someone set a header there it would might override the way the original code worked.
    If there is a background image there perhaps you can reselect the original image?

    I “think” you could just remove this from your function:
    $output .= “#header { background: url(‘$url’) no-repeat bottom center; }

    and add
    #header { background: url(‘/wp-content/themes/default/images/kubrickheader.jpg’) no-repeat bottom center; }
    to your stylesheet.

    That should do what you need.

    As always, backup and save a copy of the file. don’t do it from the Editor in WordPress, use FTP.

    Hi, Kim,

    Hooray! You did it! Check it out! https://freddiegershon.com/freddiesblog/

    But the BG is a little wider than the area below it. I tried tweaking the headerimg dimensions but nothing happened. Any suggestions?

    #headerimg {
    /*margin: 7px 9px 0;*/
    margin: 6px 8px 0;
    height: 192px;
    /*width: 740px;*/
    width: 736px;
    }

    I also tried it with the top code here turned on and off, to no effect.

    #header {
    background: #73a0c5 url(‘images/kubrickheader.jpg’) no-repeat bottom center;
    }

    #header { background: url(‘/wp-content/themes/default/images/kubrickheader.jpg’) no-repeat bottom center; }

    Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.