Support » Plugin: Top 10 - Popular posts plugin for WordPress » TOP 10 > WP 4.7 > PHP 7.1 > Dashbord > Startpage

  • Resolved WiKaBot

    (@wikabot)


    WordPress > Dashboard > Startpage
    only some widgets show up, not all

    impossible to click on customize view or Help on that page

    happens only with php 7.1 on all of my sites which where running this constellation (all https) WP 4.7 an PHP 7.1 AND TOP 10 … after disabling TOP10, the behavoir is normal.

    Please check this

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Ajay

    (@ajay)

    Can you post some screenshots of this?

    • This reply was modified 4 years, 4 months ago by Ajay.
    Thread Starter WiKaBot

    (@wikabot)

    Yes I can, but it will help you only a little.
    I think you can reproduce the Bug in an Environment described above, I could this several times.
    WP 4.7 and PHP 7.1 (lower Versions, especially 5.6 is working well with Top 10)
    To ensure this, in two cases top 10 was the only active Plugin.

    The shortest way would be, to invite you (as admin) into a site thats just experimental the next weeks. Please send me your email address at this: top10(at)wikaleaks.org and I will give you an Admin account as long as we are hunting the bug. At the same address I’ll send you the screenshots … if necessary.

    Plugin Author Ajay

    (@ajay)

    I was able to replicate the error.

    The quick fix was to edit line 291 in includes/public/display-posts.php and declare it an array instead of a string

    
    	$fields = array();
    
    Thread Starter WiKaBot

    (@wikabot)

    Hi Ajay,

    thanks for that, now everything works as expected again … πŸ˜‰ 😊

    Plugin Author Ajay

    (@ajay)

    Thanks for confirming. I’ll put this fix through for the next version of the plugin.

    Do let me know if you spot other bugs that have cropped up specifically in 7.1 as it is a new world out there for now.

    Thread Starter WiKaBot

    (@wikabot)

    I’ll do … if I find some more 🐞 of that kind … 😎 … have a good Weekend.

    I had experienced the same problem and fixed with the solution of replacing that line. Waiting for a new release of the plugin.

    Thanks.

    Changing line 291 worked for me on Top 10 v2.4.2, WordPress 4.7.3, PHP 7.1.2.

    This resolved an admin dashboard left panel submenu popout on hover issue I was experiencing also.

    This resolved the Top 10 widget in (any of) my sidebars stopping output of the rest of my widgets. Sidebar was blank if I tried to load this widget.

    Plugin Author Ajay

    (@ajay)

    Thanks all for the feedback. I haven’t pushed a release yet because I was hoping to identify / fix other bugs, if any.

    But, will do so over this weekend when I get access to my main coding machine

    Plugin Author Ajay

    (@ajay)

    I pushed v2.4.3 out

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘TOP 10 > WP 4.7 > PHP 7.1 > Dashbord > Startpage’ is closed to new replies.