Support » Plugin: TooltipGlossary » TooltipGlossary & Cyrillic

Viewing 6 replies - 1 through 6 (of 6 total)
  • I faced same problem.

    tooltipglossary works fine only with Latin characters I tried to use it for Arabic terms but it failed!

    After some researches I noticed that tooltipglossary calls limited characters during link search process through the following regular expression
    $link_search = '/<a'.$timestamp.'>('.$glossary_item->post_title.'[A-Za-z]*?)<\/a'.$timestamp.'>/i';
    I tried to modify it for enabling all character sets but it didn’t work!

    So does anyone help us for making tooltipglossary available to all languages?

    I forgot to tell you that I don’t have any experience in PHP i’m just C++/Qt developer.

    Plugin Author jatls

    (@jatls)

    The regex characters you have pointed to are simply there as a redundancy to ensure that all terms are identified correctly. What you have referenced is actually called after the term is first identified.

    I have little experience with non-Latin character sets however I don’t see a reason why the search function should fail. As long as the title of the glossary item exactly matches the term in a post it should be found. The first thing I would check is that the database is properly storing your terms and that your posts do contain the exact match. The reason I say to check the database is that often times the software will display the information differently than it is displayed. If WP is doing some sort of character conversion then that may be the cause of the problem.

    For your reference (and so you can do any checking/testing) the regex that identifies search terms is as follows:
    '/\b'.$glossary_title.'s*?\b(?=([^"]*"[^"]*")*[^"]*$)/i'
    While this looks complicated, it simply searches for the glossary term (plus or minus an ‘s’ character for plurals in English – which is completely optional so that wont affect anything with foreign languages) between word boundaries. The part in brackets at the end excludes it from searching within the tooltip when enabled and the /i at the end makes sure the search is case insensitive.

    I’m happy to make any changes if necessary but I cannot troubleshoot these problems with my current setup. Any assistance with troubleshooting and identifying any changes would be much appreciated.

    mbnoimi

    (@mbnoimi)

    Thanks for reply jatls,

    however I don’t see a reason why the search function should fail. As long as the title of the glossary item exactly matches the term in a post it should be found.

    I published a test for this issue see the glossary page please.

    PS
    See the following screenshots to in case your browser doesn’t support Unicode.

    http://i.imgur.com/rEeI6.jpg
    http://i.imgur.com/lUCfD.jpg
    http://i.imgur.com/bjqIU.jpg
    http://i.imgur.com/nm2uS.jpg

    View post on imgur.com

    hi, can someone help to so that i am able to find a match within a particular css tag.
    i.e search for book where book is inside css class <div id="mybook">books</div>

    Hi Jatls,
    congratulations for this cool plug-in. I’ve installed TooltipGlossary on a french blog. It’s OK with words without latin character, but when I create a new glossary with latin characters, TooltipGlossary don’t create the link.
    Example : In my post’s text, there is this word écranté, and after I create a écranté glossary, the plug-in don’t create any link for this word.

    If I wrote ecrante in this post and create ecrante glossary, the link is created and the tooltip appears on rollover…

    In my language (french) we found those characters :
    ’ïîéèëêàäâôÔÉÈÊËÀæāÆœŒÇ瀅
    In URL rewriting the replaces can be :

    • ï,î replaced by i
    • é,è,ë,É,È,Ë replaced by e
    • ô,Ô,ö,Ö replaced by o
    • æ,Æ replaced by ae
    • œ, Œ replaced by oe
    • ç,Ç replaced by c

    How can I set the plug-ins to replace and running this glossary ?

    Thank’s a lot

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘TooltipGlossary & Cyrillic’ is closed to new replies.