Support » Plugin: Interactive Geo Maps » Tooltip content issues in Safari

  • Resolved vderdg

    (@vderdg)


    Hi! Sorry to trouble you again.
    I was recently informed that there are some display issues in Safari.
    The images in the tooltip are not displayed at all, or they are shown randomly in the page outside the tooltip.
    I’ve uploaded a demo site with nothing more than the plugin and de default wp theme (to prevent this to be a css error of my theme).
    In chrome and firefox everything seems to be working fine.

    This is the demo site.
    Example site

    Here is a screenshot of Safari display:

    Could you please give some advice in how to procede?
    Thanks in advance.
    Kind regards.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    Hi @vderdg
    Check if the tips on this page help:
    https://interactivegeomaps.com/docs/tooltip-image-in-the-wrong-position/
    Greetings, Carlos

    Thread Starter vderdg

    (@vderdg)

    Hi Carlos, thanks a lot!
    I’ve applied the documentation solution (sorry i didn´t see it before).
    But apparently the issue persist but in a weird way. The first time they use the map in Safari the content has the same visibility issues. But if they continue to navigate it for a while the issue starts to dissapear and the content stars to look alright.
    I’m kind of lost on how to locate the issue since the css is already modified with the fix (and the content seems to “fix itself”).

    Thanks again and happy holidays.

    Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    Hi @vderdg
    Is this happening on the page you shared previously?
    http://www.defensapersonalrosario.com.ar/bruju/pagina-ejemplo/
    Or a different page?
    Do all images in the tooltip have the width=” height=” parameters? Usually it helps if you have the width and height there also.

    Thread Starter vderdg

    (@vderdg)

    Hi Carlos, thanks a lot for your response.
    The production site is this
    The images do have the width and height parameters.

    Thanks again.
    Happy holidays.

    Plugin Author Carlos Moreira

    (@carlosmoreirapt)

    If the images all have the same height, try completing with this css:

    .imapsLabel foreignObject img { 
        min-height:57px !important;
    }	

    Greetings, Carlos

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.