Support » Plugin: TinyMCE Advanced » Tools doesn't show in TinyMCE Advanced Editor

  • Hi,

    I have TinyMCE Advanced Editor installed with a Genesis Framework but the “Tools” drop-down menu doesn’t show in the editor?? I really need to use the “Source code” I have tried to activate the “Source code” button manually (under “unused buttons” in the TinyMCE Advanced Editor settings but it doesn’t show.

    Please advise,
    ATB
    Morten

    https://wordpress.org/plugins/tinymce-advanced/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    WordPress Dev

    Sounds like “something” is disabling the Tools menu and removing the “Source code” button… They definitely don’t want you to see what’s going on in there 😉

    Jokes aside, this is done either by another plugin or by your theme. Searching for things that use the 'tiny_mce_before_init' filter in the source of your plugins and themes will probably find it.

    Another way this could be done is by JS modifying the TinyMCE init settings, or even just hiding the menu and button with some CSS. You should be able to see the latter from the browser tools.

    Hi Andrew,

    I flushed the cache and that solved the problem 🙂

    Thanx for a good plugin.

    Atb
    Morten

    stefen8

    (@stefen8)

    Hi,

    I had the same problem of disappearing “code source” button.
    Always after saving TinyMCE Advanced Options, this button and Tools menu were going away.
    The only way the get it back was to reset default options.

    I just had a look at tinymce-advanced.php file, fonction get_plugins(), and i add following instruction :
    if (in_array('code', $this->used_buttons, true)) $plugins[] = 'code';

    Now it works for me, i have my nice code button and tools menu, event after saving options.

    Thanx for your plugin.

    • This reply was modified 1 year ago by  stefen8.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Tools doesn't show in TinyMCE Advanced Editor’ is closed to new replies.