Support » How-To and Troubleshooting » Toolbar – WYSIWYG editor has gone

Toolbar – WYSIWYG editor has gone

  • Hi,

    After updating to WP 2.8 my WYSIWYG editor has gone where i edit posts. All that shows now is the upload/insert options!

    If anyone can help that would be great!


Viewing 15 replies - 1 through 15 (of 16 total)
  • some folks have reported that if they go to their profile in admin and check to disable wysiwyg editor – view a post in edit mode – then put back visual editor , it will work again.

    thanks for that samboll, i tried this but it still doesnt bring anything back when i click on the ‘visual’ tab.

    Has anybody else had this problem and found a fix?

    yes, me and ir terrible now… i can’t work with just the html editor… help¡¡¡

    …and me! _ I have the same problem and have come here to find an answer. Hope someone who knows will see this thread….

    Moderator Andrew Ozz


    WordPress Dev

    Perhaps try the suggestions here: http://wordpress.org/support/topic/279132

    Thank you, Azaozz, I’ve just carried out the simpler of those tasks (some of them are beyond my capabilities at present) but the problem is still not fixed yet.

    I use Chrome normally, but opened a ‘add new post’ page in ie, where I have debugging enabled, and it told me this (even though I have not got Tiny MCE enabled, just installed though):

    Line: 1
    Error: ‘tinyMCE’ is undefined

    ‘tinyMCE’ is undefined wp-langs-en.js?ver=3241-1141, line 1 character 1

    and this is first line, as is at present::


    What – are where – would I need to add to this please??

    Just to help with elimination of probably causes, I use Hostgator hosting – who else, with the same problem, uses Hostgator?

    any offers, please, for the above?? 😉

    It happen to me a day or two after i installed 2.8 when they released it.

    I dun know what happen actually but the day after it, it is fixed already.

    So i thought it was just my connection problem that make it failed to load the function.

    Didn’t know it was really an actual error.

    Here’s how I just fixed my site:

    1. Disable all plugins.

    2. Download the latest version of WP from WordPress › Download

    3. Upload the following directories/folders using http://FTP...


    4. Reactivate your plugins, and you should be good to go.

    5. If this fails then upload all the WP files via FTP.

    Moderator Andrew Ozz


    WordPress Dev

    @speedmouse perhaps try replacing (delete and then upload again with FTP) the wp-includes/js/tinymce directory. If you’re not using TinyMCE make sure the “Disable the visual editor when writing” checkbox in your profile is checked. That will stop loading of all editor files.

    Hi everyone,
    just to say that Samboll’s suggestion worked fine for me:

    1- go to Users > modify (under USERNAME)

    2- check the “Disable editor” option

    3- save the changes

    4- uncheck the “Disable editor” option

    5- save the changes again.

    Pretty weird but it worked (Safari 4 on Mac os 10.4, Firefox 3.0.11).

    In my opinion it is the hardest wp upgrade ever since 2.5.

    Thanks, have a good day,

    Hey everyone,

    I recently upgraded to 2.8 and encountered the exact problem…no tinymce editor!

    Here’s the fix I used:

    1. Download the latest version of WP to your desktop
    2. Extract all the files
    3. Open up your site using FTP
    4. Locate wp-includes>>>js>>>tinymce
    5. Delete the the tinymce folder
    6. Create a new directory named tinymce. Same name same location as the old one
    6. Locate the tinymce folder on your desktop
    7. Upload all it’s contents to the new tinymce folder you created

    You should be good to go. I tried everything else above but nothing worked for me except replacing the existing files.


    try disabled gears. it works for me

    I also have this problem in two different WP 2.8 installations. In one, the Visual Editor has gone and following the suggestions above has not helped, even a complete re-install. Should I roll it back? The users won’t use the html version. In the other installation, the html editing is not available. Very disappointed.

    SInce i’ve upgraded to 2.8.4 i’ve got my WYSIWYG editor is not complete anymore.

    Only one bar of buttons is shown

    This is what i see:

    And this is normal:

    I’ve upgraded again, disable an enable the WYSIWYG editor, disable gears but no effect at all.

    Any suggestions?

    Thanks in advance!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Toolbar – WYSIWYG editor has gone’ is closed to new replies.