WordPress.org

Forums

Toolbar - WYSIWYG editor has gone (17 posts)

  1. indu76
    Member
    Posted 5 years ago #

    Hi,

    After updating to WP 2.8 my WYSIWYG editor has gone where i edit posts. All that shows now is the upload/insert options!

    If anyone can help that would be great!

    thanks

  2. Samuel B
    moderator
    Posted 5 years ago #

    some folks have reported that if they go to their profile in admin and check to disable wysiwyg editor - view a post in edit mode - then put back visual editor , it will work again.

  3. indu76
    Member
    Posted 5 years ago #

    thanks for that samboll, i tried this but it still doesnt bring anything back when i click on the 'visual' tab.

    Has anybody else had this problem and found a fix?

  4. chuurr
    Member
    Posted 5 years ago #

    yes, me and ir terrible now... i can't work with just the html editor... help¡¡¡

  5. speedmouse
    Member
    Posted 5 years ago #

    ...and me! _ I have the same problem and have come here to find an answer. Hope someone who knows will see this thread....

  6. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    Perhaps try the suggestions here: http://wordpress.org/support/topic/279132

  7. speedmouse
    Member
    Posted 5 years ago #

    Thank you, Azaozz, I've just carried out the simpler of those tasks (some of them are beyond my capabilities at present) but the problem is still not fixed yet.

    I use Chrome normally, but opened a 'add new post' page in ie, where I have debugging enabled, and it told me this (even though I have not got Tiny MCE enabled, just installed though):

    Line: 1
    Error: 'tinyMCE' is undefined

    'tinyMCE' is undefined wp-langs-en.js?ver=3241-1141, line 1 character 1

    and this is first line, as is at present::

    tinyMCE.addI18n({en:{

    What - are where - would I need to add to this please??

    Just to help with elimination of probably causes, I use Hostgator hosting - who else, with the same problem, uses Hostgator?

  8. speedmouse
    Member
    Posted 5 years ago #

    any offers, please, for the above?? ;)

  9. neorackle
    Member
    Posted 5 years ago #

    It happen to me a day or two after i installed 2.8 when they released it.

    I dun know what happen actually but the day after it, it is fixed already.

    So i thought it was just my connection problem that make it failed to load the function.

    Didn't know it was really an actual error.

  10. buzzardian
    Member
    Posted 5 years ago #

    Here's how I just fixed my site:

    1. Disable all plugins.

    2. Download the latest version of WP from WordPress › Download

    3. Upload the following directories/folders using http://FTP...

    wp-content
    wp-include.

    4. Reactivate your plugins, and you should be good to go.

    5. If this fails then upload all the WP files via FTP.

  11. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    @speedmouse perhaps try replacing (delete and then upload again with FTP) the wp-includes/js/tinymce directory. If you're not using TinyMCE make sure the "Disable the visual editor when writing" checkbox in your profile is checked. That will stop loading of all editor files.

  12. natolie
    Member
    Posted 5 years ago #

    Hi everyone,
    just to say that Samboll's suggestion worked fine for me:

    1- go to Users > modify (under USERNAME)

    2- check the "Disable editor" option

    3- save the changes

    4- uncheck the "Disable editor" option

    5- save the changes again.

    Pretty weird but it worked (Safari 4 on Mac os 10.4, Firefox 3.0.11).

    In my opinion it is the hardest wp upgrade ever since 2.5.

    Thanks, have a good day,
    Enrico

  13. seolun4tic
    Member
    Posted 5 years ago #

    Hey everyone,

    I recently upgraded to 2.8 and encountered the exact problem...no tinymce editor!

    Here's the fix I used:

    1. Download the latest version of WP to your desktop
    2. Extract all the files
    3. Open up your site using FTP
    4. Locate wp-includes>>>js>>>tinymce
    5. Delete the the tinymce folder
    6. Create a new directory named tinymce. Same name same location as the old one
    6. Locate the tinymce folder on your desktop
    7. Upload all it's contents to the new tinymce folder you created

    You should be good to go. I tried everything else above but nothing worked for me except replacing the existing files.

    Cheers

  14. zaryl
    Member
    Posted 5 years ago #

    try disabled gears. it works for me

  15. brettreasure
    Member
    Posted 5 years ago #

    I also have this problem in two different WP 2.8 installations. In one, the Visual Editor has gone and following the suggestions above has not helped, even a complete re-install. Should I roll it back? The users won't use the html version. In the other installation, the html editing is not available. Very disappointed.

  16. margjedonder
    Member
    Posted 5 years ago #

    SInce i've upgraded to 2.8.4 i've got my WYSIWYG editor is not complete anymore.

    Only one bar of buttons is shown

    This is what i see:

    And this is normal:

    I've upgraded again, disable an enable the WYSIWYG editor, disable gears but no effect at all.

    Any suggestions?

    Thanks in advance!

  17. margjedonder
    Member
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic