WordPress.org

Forums

TinyMCE Advanced
[resolved] Toolbar toggle oddities (9 posts)

  1. mbi_marc
    Member
    Posted 1 year ago #

    So working on a clean install of WP 3.9 with TinyMCE Advanced 4.0, the first thing I noticed was that I can't seem to have two toolbars visible by default; it seems I'm now required to use the "Toolbar Toggle" button, and people unfamiliar with that button will simply not see the tools in the second bar. Is this correct? Is this intended?

    Secondly, in order to try to alleviate the above, I tried moving all buttons to the first bar (hoping against hope that they'd just wrap), and removing the "Toolbar Toggle" button. When trying to save, I get the error message:

    The "Toolbar toggle" button shows/hides the second, third, and forth button rows. It will only work when it is in the first row and there are buttons in the second row.

    Seeing as how the "Toolbar toggle" button was not in use, and no buttons were in the 2nd, 3rd, and 4th rows, that error seems to be appearing in error.

    https://wordpress.org/plugins/tinymce-advanced/

  2. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    Possibly caused by stale cache. If you clear the browser cache and click the "Restore Default Settings" button, the "Toolbar toggle" should be the last button on the first row. Then you can drag it out of there. Two rows work as before.

  3. mbi_marc
    Member
    Posted 1 year ago #

    I don't think it's a cache issue. I normally run with a maximum cache size of 0. However, to double check, I cleared my cache anyways, clicked "Restore Default Settings", and I still can't get two rows to display.

    I even opened up a browser that had never visited the site in question (Safari 5.1.7 on a PC), and it's having the exact same issue. With the toolbar toggle button active in the first row, the second row is hidden (as expected). Removing the toolbar toggle button and saving, the second row remains hidden.

    I have no other plugins active, and updated to 4.0.1 prior to all of that.

  4. mbi_marc
    Member
    Posted 1 year ago #

    I just realized that my initial post was somewhat misleading on one point- I said it was a "clean WP 3.9 install", but actually it was a 3.8.3 install that was immediately updated to 3.9. Not sure if it makes a difference, but I thought I should correct myself there.

    Is there anything else I can try?

  5. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    Ah, I understand the problem now, thanks. Even after removing the Toolbar Toggle button, the second row is automatically hidden when the editor loads, and there is no way to show that row. This happens as WordPress stores a setting whether to load the editor with that row shown or hidden.

    A workaround for now would be to add the toggle button, go to the Edit Post screen, show the second row, reload the page to confirm the row is shown, then remove the toggle button.

  6. mbi_marc
    Member
    Posted 1 year ago #

    Your workaround works! Thanks for your assistance.

    I'll mark this as resolved, as I won't remember to come back and do that when a permanent fix goes out. :)

  7. MixFruitSalad
    Member
    Posted 1 year ago #

    A workaround for now would be to add the toggle button, go to the Edit Post screen, show the second row, reload the page to confirm the row is shown, then remove the toggle button.

    Andrew, same problem is happening with my editors and myself too in other wordpress websites. Curious this: This website (MixFruitSalad.com) has no issues with 2nd or 3rd row with me but my editor is having my problem. My another website is having this issue which has freshly installed WP 3.9 today with this plugin installed of latest version. I dont understand what the problem is :D

    So...you told "go to the Edit Post screen". What are you pointing? where is this screen? And in this support query, someone just wrote this code:

    .mce-toolbar {
    display: block !important;
    }

    So does that make any difference? Please tell me how to proceed and how to enable showing 2nd and 3rd row to my users and editors....and myself.

  8. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    @MixFruitSalad, download the latest dev. version, should be fixed there for all users.

  9. MixFruitSalad
    Member
    Posted 1 year ago #

    Hello Sir.
    I reinstalled wordpress 3.9, started everything from new. Installed the latest version of this plugin.
    The problem persists. I am trying to keep necessary tools on row 1 only. Solution?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic