Support » Plugin: Hide My WP Ghost - Security Plugin » toolbar palette icon

  • Resolved spike210957

    (@spike210957)


    Hi,

    With hide my ghost turned on in safe mode some of my users cannot use the palette icon in the wp-toolbar. The palette icon is visible but when you hover it does not display “Dashboard, Themes, Widgets, Menus’. Turn hide my ghost off and it works again.

    Is there a workaround?

    Nigel

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi, Make sure you have the Hide My WP > Tweaks > Change Paths for Logged Users switched off. This way, Hide My WP doesn’t load while users are connected to your website.

    John

    I have actually removed the whole plugin, changed .htaccess back to the default, purged my varnish cache, restarted apache and deleted by local cache. But still having problems. Does Hide my WP leave anything behind in the database that I need to get rid of?

    I think I have found the culprit Health Check and Troubleshooting is reporting the the REST API is returning an unexpected result. How do I turn it back on?

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API call gave the following unexpected result: (403) {“code”:”rest_forbidden_context”,”message”:”Sorry, you are not allowed to edit posts in this post type.”,”data”:{“status”:403}}.

    Once you remove the plugin, the database record with the settings is also removed.
    The database line is hmw_options located in the table wp_options.

    If you removed the .htaccess file rewrite rules for Hide My WP, it should work like before.

    Update the settings in Settings > Permalinks to make sure WordPress is adding the default rules in the .htaccess file.

    Best, John

    I checked the default REST API for your website and it’s working okay.

    https://westerly-owners.co.uk/wp-json

    John

    Ok I reset the permalinks a couple of times and have completely deleted the .htacess which has then be recreated with the default settings.

    Still not working any other suggestions?

    Did you set the REST API in the application as https://westerly-owners.co.uk/wp-json ?

    I can see the website working without any JS or CSS issue.

    Can you tell me what exactly is not working?

    I’m not sure where the REST API is configured in wordpress. The first time I became aware of it was using WP ghost and I did disable it which then gave me problems because I couldn’t create posts because the block editor uses it. But if I understand you correctly disabling REST would happen because GHOST rewrites the rules in .htaccess.

    As .htaccess is back to default REST should be enabled?

    So what can’t I do. If I go to new on the toolbar there is no option for post. The palette icon does not work. Once I am in the backend I cannot see any classifieds from my WP Adverts. I think this is because posts have become disabled….

    Very happy to give you admin access if that helps….

    If I do

    https://westerly-owners.co.uk/wp-admin/

    I get a message “Sorry you are not allowed to access this page”

    However if I edit my home page

    https://westerly-owners.co.uk/wp-admin/post.php?post=2407&action=edit

    it’s quite happy…I’m thoroughly confused….

    I have nailed it. In the Members plugin role system I have two administration roles. Administrator and WoaAdmin (cut down which prevents changing plugins/themes etc) I give this to some of the users. Now in both of these Edit Posts capability had not been granted. These must have been granted previously because everything was working.

    So I’m still mystified how they were changed. I haven’t knowingly done it myself and I’m the only Administrator…..relieved to have gotten to the bottom of it (sort of)….

    thanks for your help….

    N.

    Great that you managed to figure out the problem.

    We will test the Hide My WP roles again and see what could cause this issue on plugin deactivation.

    I will let you know what we find.

    John

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘toolbar palette icon’ is closed to new replies.