WordPress.org

Support

Support » How-To and Troubleshooting » Toolbar Not Showing on the Site?

Toolbar Not Showing on the Site?

  • Hello!
    The upper Admin bar/toolbar isn’t showing while visiting/viewing my site after log-in as admin. It is showing on the admin panel but when I click on Visit Site from dashboard or manually visit my site it disappears on the site even though I’m still logged in as admin and have already checked this option from my profile “Show Toolbar when viewing site”.

    Thanks in Advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Have you tried the show_admin_bar(true) in your functions.php ?

    Yes I tried this function, the toolbar is now visible on the site too..
    but problems:

    1- No options visible on that bar.
    2- It’s visible to every-one, all the visitors of site can see it.

    Should you need an access only for admins, you better use the filter checking for the appropriate access, such as:

    if (! current_user_can('manage_options')) {
    	add_filter('show_admin_bar', '__return_false');
    }

    any plugins installed? i just installed a plugin that does just that. removes the toolbar from the front end.

    This issue often creeps up when moving WP directories. This is usually a cookie issue. Clear out the cookies for the site you are working on. This will log you out. Log in and you should once again see your address bar.

    You might also want to check Users > Edit to be sure that “Show Toolbar when viewing site” is checked.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Toolbar Not Showing on the Site?’ is closed to new replies.
Skip to toolbar