Support » Plugin: Secure Image Protection » Too risky

  • You have to install Java to get this plugin to work. Maybe your images are secured but anything else not, since Java is a security risk for your whole system.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ArtistScope

    (@artistscope)

    Dunno where you get that nonsense.

    Plugin Author ArtistScope

    (@artistscope)

    Java should be sandboxed from the user’s system. That is the way that it was designed and used for 30+ years… it has always been the safest solution for apps and plugins because it could do no harm.

    So if today there are claims about it being unsafe, those claims are suspect. Many companies have tried to claim Java as their own and got their fingers burnt. In retaliation they made it difficult to integrate Java with their apps.

    But now that those companies are wanting to build “run anywhere” apps for mobile phones and other amusement devices, they are opening their systems to utilise Java, and it is those companies that are an unsafe risk, not Java.

    Anyway, Java applets will only run in a web browser space today if they are code-signed. Code-signing for java was not required and not easily possible until recently. All modern browsers now require code signing and also require that the user have the latest version of Java installed, so that any newly developed
    exploits are secured.

    • This reply was modified 2 years, 6 months ago by  ArtistScope.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Too risky’ is closed to new replies.