Support » Everything else WordPress » “Too Many Requests” when trying to checkout plugin

  • Hi,
    Not sure if this is a wordpress issue, or our build server (TeamCity) but, when we are trying to checkout our website from our svn repo, we are trying to pull plugins from the plugins.svn.wordpress.org directory, but we are getting an error
    “429 Too many Requests”

    Full Error:
    “[Updating sources] Failed to perform checkout on agent: java.lang.RuntimeException: java.lang.RuntimeException: java.lang.RuntimeException: org.tmatesoft.svn.core.SVNException: svn: E175002: PROPFIND of ‘/akismet/tags/4.1.3’: 429 Too Many Requests (https://plugins.svn.wordpress.org)”

    Not sure if we have been put on a blacklist by wordpress or if its an issue with something else.

    Any advice would be great.
    Thanks.

    • This topic was modified 3 weeks, 2 days ago by Jan Dembowski. Reason: Moved to Everythng else WordPress, this is not a Developing with WordPress topic. It's an infrastructure topic
Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Yes, rate limiting has been added to the SVNs for some blocks of servers, due to increased traffic coming from those systems. You can try to do the checkout from some other server instead, or just manually install those plugins.

    Thank you for getting back to me.
    Is it possible to get our server unblocked and let me know the limits so that i can modify the times on the server at all please?

    Its quite an impact on our work flow not being able to checkout the source from that particular server.

    Many Thanks

    @otto42

    This is also affecting us running testing through CircleCI. Is there a plan to get certain servers unblocked, or at least a way to remove the plugin dependencies from the https://develop.svn.wordpress.org/tags/5.3/tests/phpunit/data/ checkout?

    The new rate limiting means that we can no longer have any CI testing.

    Edit: For anyone else coming here with questions about CI testing, we found a solution by adding the --ignore-externals flag to the end of the svn co command.

    • This reply was modified 3 weeks, 2 days ago by Seth Alling. Reason: Found a solution for CI testing
    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You would have to ask the systems team about that. This is not under my control.

    How would i go about contacting them,
    I thought putting a thread here in the support section would be able to reach who i need?

    Thanks.

    Looks like a trac ticket’s been opened up about this: https://meta.trac.wordpress.org/ticket/4869

    I’ve submitted a pull request to WP-CLI to make --ignore-externals the default behavior in install-wp-tests.sh

    Thanks @sethta for the great tip!

    Our deployment pipeline is broken and we cannot omit our svn externals during the process. Is there a way to contact systems team? It’s very frustrating.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.