Support » Plugin: W3 Total Cache » Too many redirects when using subdomain to reach wordpress homepage

  • Resolved kcaluwae

    (@kcaluwae)


    When I enable page caching I experience an error that I can no longer reach my wordpress homepage from my subdomains.

    My wordpress site is hosted in http://www.wapititravel.com/blog
    I have created a subdomain blog.wapititravel.com.

    A-records ensure that also https://www.wapititravel.com directly redirects to the blog.

    All works fine until I enable page caching. I don’t see any other issues. When I directly go to a blog post this seems to work fine, only those “redirects” are affected.

    Disabling front page caching doesn’t help.
    My DNS is managed by Cloudflare.

    At this point I have no clue where to look, it would be great if you could point me in the correct direction.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    If you want the website to be available on blog.website.com, you should change the domain in Settings => General to blog.website.com instead of http://www.website.com/blog/
    If the redirect doesn’t work, it means that you have added the redirect incorrectly. You should do a redirect directly in the DNS. If that’s not an option, point the root directory for the www domain to the root directory for the subdomain. Then WordPress will redirect automatically to the domain set up in Settings => General.

    It looks like I could solve the problem by implementing a page rule in Cloudflare.

    I don’t get why it was working before without this rule, the redirect just magically worked.

    Anyhow, most important things is that it is working now and that I can enable page caching!

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Too many redirects when using subdomain to reach wordpress homepage’ is closed to new replies.