Support » Plugin: WooCommerce » “Too many redirects” error – related to shipping settings

  • Resolved treatsun

    (@treatsun)


    I am getting the “Too many redirects” error on my site after adding a second shipping zone. I’ve deleted the zone but the only way to resolve the error has been to restore the site.
    I was trying to set up a local zone with definied zip codes and 3 shipping zones (flat rate, local delivery and free shipping). Making any changes to the zones starts the Too Many Redirects error on the site. I can access the dashboard with no problem.

    I did have Local Pick up Plus installed. After the first restore, I have deactivated it and the problem continues. I’m just editing the basic shipping tab in Woocommerce settings.
    Until yesterday, I had a zone of Everywhere (United States) and a flat rate shipping method. My end goal is to have a local zone with delivery and pickup methods and an Everywhere Else zone for flat rate shipping outside the local zone.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve gotten this narrowed down.
    I can set up two zones – US and Local (with my state) and it works fine.
    I can set up a flat rate shipping method for US and two shipping methods for Local – flat rate and local pick up – and it works fine.
    As soon as I add a 3rd shipping method for Local – free shipping with a minimum order of $50, the site goes down with “Too Many Redirects” and I can’t get it back. I’ve tried deleting the method but still get the same error until I restore the site.
    Any ideas about why this happens or how to get the site back without restoring?

    Plugin Support rossviviano

    (@rossviviano)

    Automattic Happiness Engineer

    Hi there,

    This issue is likely do to a theme or plugin conflicting with WooCommerce. To test, first, you’ll want to change the theme on your site to Storefront, then test. If that resolves the issue, you’ll want to get in touch with your theme’s developer and see if they have an update or fix for you. If changing the theme doesn’t help, you’ll want to deactivate all plugins except for WooCommerce and take a look. If that fixes the problem, re-enable the other plugins one by one to see where the issue is coming from. If you don’t want to test on your live site, then create a staging site using a plugin called WP Staging.

    Best,

    Ross

    Plugin Support rossviviano

    (@rossviviano)

    Automattic Happiness Engineer

    Hi there,

    I’m going to resolve this thread as I haven’t heard back from you in a while. If you have any other questions, feel free to start a new one.

    Ross

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.