Support » Fixing WordPress » Too many redirects after 4.4.1 update

  • My sites automatically updated from 4.4.0 to 4.4.1 yesterday – I tried to login this morning and couldn’t due to too many redirects error.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I had the same issue on my site this morning after the automatic update to 4.4.1. Too many redirects on the home page but every other page was working fine.

    After a bit of investigation, I downgraded to 4.4 (4.4.0) and the issue went away. I believe this is a bug in 4.4.1.

    Rob

    I have the same problem. I figere out that happened on pages or posts where I have iframe included (iframe or youtube link).

    How are You downgrade to 4.4.0? Just owerwrite the files with 4.4 zip?

    I’m on 4.4.1, too. I updated a few days ago, and all was well until today. I have exactly the same problem – too many redirects on home page, but other pages accessible. I’ve put a temporary redirect on the home page, which provides a restricted site, but allows visitors to see something. I suppose I could downgrade. For now, I’ll watch this space.

    I disabled all plugins, but there was no change.

    I have another instance of WordPress 4.4.1 running on the same server, with different theme, and that’s working just fine.

    I do hope someone comes up with an answer.

    Henry http://Bennyblog.no-ip.org

    Same issue, too many redirects, but in wp-admin only – the website wasn’t affected. I rolled back to 4.4.0 (by overwriting the files from the official 4.4 distribution), and disabled automatic updates (for now).

    I’ve been struggling for an hour with the identical issues, restoring, then updating, then restoring again. Going to leave it at 4.4 for now. Glad I found this post as I thought I had broken something.

    For me, the problem arises whenever I set a static front page. For now, I’m ok with landing on latest blog entry and adding a Home page to the navigation menu. Not great, but ‘what can you do?’

    You have to contact your hosting company and get them to fix it on their end.

    This is from 2 hours ago on WordPress support:
    “cPanel users may find wp-admin blocked due to an update to their server’s mod_security rules. Preliminary reports suggest rules #214620 and #214940 are to blame. Please contact your hosting provider if you encounter this.”

    I just spent an hour online with my hosting provider, and they created a workaround so I could get into my site.

    same here. After automatic update to 4.4.1, I’m getting “too many redirects” on the main page. This only happens (in my case) when a load balancer is used. (apache load balancer) I temporarily disabled LB and it is now fine. I hope wp fixes this soon.

    There is some confusion around two different issues that have been reported and are often mixed in various Support Topics. Both occur after a website has been updated to 4.4.1 and result to a redirect loop

    1. Redirect loop on the homepage. Every other page and the dashboard can be accessed without issues. This problem seems to occur when the site has a mixed case URL set in WordPress. Here is a link to the fix by Marius (Clorith). Changing the urls to all lowercase should fix it.

    2. Redirect loop when trying to log in to the dashboard. The front end of the side can be accessed without issues. This seems to be a server issue regarding the mod_security rules as explained above by Americaninlima. You may have to contact your hosting provider, or disable the two rules if you run your own server for this one.

    I hope this helps.

    Thanks KostasNi for clarifying.

    For #2, does anybody know if there is an official statement from WordPress? I can’t find the original post that Americaninlima is referring to.

    I could try asking my hosting if it’s safe to remove those two mod_security rules, but I would need something official that I can reference.

    Thanks!

    Hi disgracesonthemenu, you can point them to this post. That is the most official reference there is.

    Thanks KostasNi – I went to the post by Marius and I think the thread may have been closed too early. When I changed wp-config to all lower case letters and reset Permalink to Post Name, it did fix getting to the HOME page, but then I began getting “Error 404 – Not Found … The document you are looking for may have been removed or re-named. Please contact the web site owner for further assistance.” errors when I tried to get to the other pages.

    Does anyone have a suggestion that will correct both issues?

    I had the same problem but had only lower case characters in my URLs. I suspect my case is quite rare, but in case it helps anybody…

    I haven’t had time to properly look into it yet, but for me the problem is related to me using the ‘root-relative-urls’ feature of my Roots-based theme. A filter is applied to various WP functions to remove the http://[domain.com] and leave only a root-relative URL. I included home_url() as one of the functions to be filtered and this is causing a redirect loop since 4.4.1. I suspect the redirect is originating in canonical.php but haven’t tracked it down yet.

    Removing home_url() from the list of functions being filtered fixed the problem.

    I’ll report back if I figure out what’s going on here.

    Geez… the easiest solution after a couple of hours of searching…

    Capital letters in the SETTINGS – GENERAL – URLs

    Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Too many redirects after 4.4.1 update’ is closed to new replies.