WordPress.org

Support

Support » How-To and Troubleshooting » Too Many Redirects

Too Many Redirects

  • I beg of anyone who can; please help me.
    All of a sudden I’m getting a “too many redirects” error. I am not too tech savvy. The really difficult part is that the site will load when I type in http://www.HairAndMakeupBlog.com. But when I post it on facebook or have anyone to click the link it says error.
    Many times I can not see the error when I look on the computer or my Iphone it works fine. But others get an error (no numbers). Also now when I manually post to facebook and mention http://www.HairAndMakeupBlog.com a random photo (that I did not disignate) from my blog arrears and next to it; error.

    I have tried disabling all of the pluggins. I have. I have put the permalinks back to default. Before this I’m not sure when I made any changes, it must have been at least a week before. I do have Yoast SEO but when I disabled it I had the same problems.

    Thank you in advance for any help. Please excuse the rambling.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Gave it a little test and all I can see is that there is a difference between the way permalinks are handled in Facebook and on your site:

    On your site, the permalinks are based on the post id e.g. http://www.hairandmakeupblog.com/?p=2417

    In facebook, the permalinks use the post title e.g. http://www.hairandmakeupblog.com/2013/03/20/giveaway-2/?fb_source=pubv1

    Maybe this is a consequence of you playing with the permalinks to fix your initial problem, but to start with, you should revert back to using post title based permalinks on your site.

    Thank you so much for getting back to me. I changed the permalink in my settings from default to the 2nd option “date and title” (which is how it was originally). To no avail.
    It still says “WordPress › Error
    http://www.hairandmakeupblog.com/
    Please Please Please help

    Too many redirects – Error 303 SOLVED: I had the same problem. I had done a bulk update of plugins. Some deactivated plugins become active when updated. One of these was Membership. This provides protected or member only access posts. Users were going to the site being directed to the protected page and being redirected back to home page and so it would go on in a loop.
    Deactivated membership. Problem solved

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Too Many Redirects’ is closed to new replies.