Support » Plugin: Super Page Cache for Cloudflare » Too many redirects

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @samhudson444 ,
    the only redirect made by this plugin is when the option SEO redirect is enabled (and it works only for logged out users and only for URLs with cache buster). Please try to disable it and retry.

    If the problem persists, please share with us your webserver error log file

    Thread Starter samhudson444

    (@samhudson444)

    Hello,

    Hmm, I get this response now after testing:

    “Page caching seems not working for both dynamic and static pages.

    Error on dynamic page (https://thisquality.com): Connection error: cURL error 28: Operation timed out after 5000 milliseconds with 0 bytes received

    Error on static resource (https://thisquality.com/wp-content/plugins/wp-cloudflare-page-cache//assets/testcache.html): The plugin is not detected on your home page. If you have activated other caching systems, please disable them and retry the test.”

    Thread Starter samhudson444

    (@samhudson444)

    Lastly forgot to add, I’ve never understood how to exclude certain plugins from joining the cache.

    For example, I have a last modified that updates live but when I refresh the page it says at 30 seconds as last modified and doesn’t change.

    How can I exclude that from being cached?

    https://i.imgur.com/67ePxcT.png

    Thread Starter samhudson444

    (@samhudson444)

    I deeply apologise for my spam,

    at the end of every link, it adds this: /?swcfpc=1 – if I remove it it does the 30 seconds freeze as said above but if I add it, the last modified updates as usual. What is causing that?

    How do I remove the /?swcfpc=1 and still cache certain parts but exclude certain plugins from being cached?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    at the end of every link, it adds this: /?swcfpc=1 – if I remove it it does the 30 seconds freeze as said above but if I add it, the last modified updates as usual. What is causing that?

    Hi @samhudson444, The ?swcfpc=1 will only show up in your links when you are logged in as an admin user. I just now checked your site as a normal user and on the front end it is not showing that. So, basically normal users can’t see this and only admin users will.

    I didn’t understand about your last modified issue, you update the last-modified time every 30 seconds? Last modified is only supposed to be updated when you update the post. And when you update any post, the system will auto-purge the caches for that post and any related pages where that post might be showing up.

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Error on dynamic page (https://thisquality.com): Connection error: cURL error 28: Operation timed out after 5000 milliseconds with 0 bytes received

    This means that after 5 seconds of waiting, your web server did not return a response and therefore it was not possible to check the cache status.

    With the next update I have increased the timeout time from 5 seconds to 10. In any case 5 seconds is already enough, I suggest you review the resources allocated to your hosting plan

    Error on static resource (https://thisquality.com/wp-content/plugins/wp-cloudflare-page-cache//assets/testcache.html): The plugin is not detected on your home page. If you have activated other caching systems, please disable them and retry the test.”

    Fixed on next update

    How do I remove the /?swcfpc=1 and still cache certain parts but exclude certain plugins from being cached?

    On next update I added an option that allow you to remove the cache buster if you use the Woker mode.

    Stay tuned πŸ˜‰

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Too many redirects’ is closed to new replies.