Support » Plugin: Contact Form 7 » Too many parentheses in message breaks submission

  • Resolved nitrospectide

    (@nitrospectide)


    We ran into an issue where a form just would not submit. I turned off our anti-spam plugin, and validation plugin, and tried it a bunch of times until I worked out that the failure was being cause by too many parentheses in the message field.

    I say “too many” just because it doesn’t error when a few are used, but it does when this message is submitted:

    ——————————

    We are attempting to use an Arrow Gold in Esri Collector (new and classic iOS versions). We are using RTK with the WisCORS VRS network, which is a NAD 1983 (2011) system. When setting up the Profile in Collector to convert from NAD 1983 to WGS 1984 Web Mercator, the collected points are shifted 3.5 ft NW.

    I contacted Esri support, and they indicated that this is related to “BUG-000115360: Data collection shift observed in Collector for ArcGIS when using an external receiver and applying a datum transformation of NAD_1983_CSRS_To_WGS_1984”. They said that it will be resolved in upcoming versions of Collector, but had no target date.

    Are you aware of this issue, and do you have any workarounds? Setting up a Profile that does a “WGS 1984 to WGS 1984 Web Mercator” (no actual transformation) seems to prevent the points from shifting, but seems to run counter to the conventional wisdom of applying a transformation to the incoming GPS points.

    My vendor (GeoMap Solutions) is also stumped, since it appears to be working correctly for them. Maybe there is something peculiar with the WisCORS correction?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    I turned off our anti-spam plugin, and validation plugin,

    What plugins are they?

    Akismet is installed, but not used for the form, CleanTalk was tied to the form, and Jquery Validation For Contact Form 7.

    I disabled all, and still had the problem.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Where can we see the website?

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What do you have in the Comment Blacklist?

    There’s nothing in there

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What configuration do you have in the Mail tab panel?

    nitrospectide

    (@nitrospectide)

    To and From email addrs that are at our domain, a Reply-To header with the [email] field, and this in the Message Body:

    [salutation] [name-first] [name-last] <[email]> has filled out the Technical Support form.

    From: [salutation] [name-first] [name-last] <[email]>

    Subject: [subject]

    Email: [email]

    Phone #: [phone]

    Company: [company]

    Industry: [industry]

    State/Province/Region: [state]

    Country: [country]

    Topic: [topic]

    Message Subject: [subject]

    Message Details: [details]

    Device: [device]

    Serial Number: [serial-number]


    This e-mail was sent from the Technical Support (English) page from the website

    ========
    And then the Use HTML content type is checked

    We also have Mail (2) set up to send TO [email] and basic From and Subject, with this Message Body:

    Message Body:
    [your-message]

    Dear [name-first],

    Thank you for contacting Eos Positioning Systems.
    We have received your message and will respond to you within 24 hours (Monday-Friday).

    For urgent inquiries, please contact us using the phone number below:

    Phone:+1 (450) 824-3325 (Canadian international rates apply)

    Regards,
    Eos

    — Please find a copy of your inquiry below —

    From: [salutation] [name-first] [name-last] <[email]>

    Subject: [subject]

    Email: [email]

    Phone #: [phone]

    Company: [company]

    Industry: [industry]

    State/Province/Region: [state]

    Country: [country]

    Topic: [topic]

    Message Subject: [subject]

    Message Details: [details]

    Device: [device]

    Serial Number: [serial-number]

    — —
    This e-mail was automatically sent from a Technical Support form on the website

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What is in the Subject?

    nitrospectide

    (@nitrospectide)

    Support Form | [subject]

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    nitrospectide

    (@nitrospectide)

    Theme:
    Kallyas

    Plugins:
    AccessPress Twitter Feed Pro
    Akismet Anti-Spam
    Anti-Spam by CleanTalk
    Better Search Replace
    Contact Form 7
    Contact Form 7 MailChimp Extension
    Contact Form 7 Redirection
    Contact Form Submissions
    Creative Clans Embed Script
    Easy Testimonials
    Jquery Validation For Contact Form 7
    Scheduled Post Trigger
    Simnor Shortcodes
    Smush Pro
    WordPress Backup & Security Plugin – BlogVault
    WP Fastest Cache
    WP Fastest Cache Premium
    WPBakery Page Builder
    WPML CMS Nav
    WPML Media
    WPML Multilingual CMS
    WPML Sticky Links
    WPML String Translation
    WPML Translation Management
    WPMU DEV Dashboard
    Yoast SEO

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try switching theme to the default Twenty Nineteen or Twenty Seventeen, and deactivating all the plugins excluding Contact Form 7 and Yoast SEO.

    I apologize for not getting back to you sooner – other things got in the way. I have done what you suggested, and it worked, then I re-activated everything, and it worked again. So I don’t know what was causing the issue. It was reproducible before, but appears to have gone away.

    Thank you very much for your help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.