Support » Plugin: Spam protection, AntiSpam, FireWall by CleanTalk » Too many MySQL processes / killing server

  • Resolved Razorfrog Web Design

    (@razorfrog)


    Hi, this has happened three times in the last 10 days. Cleantalk mysql queries fully saturated the SQL connection pool and take down all sites on the server.

    Our SQL is configured for 151 connections. 152 connections shown here: https://pastebin.com/raw/iFu2pY50

    Some kind of issue with wp_cleantalk_sfw_logs and wp_cleantalk_sfw_temp.

    My only solution has been to restart the entire server and MySQL.

    How can we adjust settings so that this does not happen again? I’d like to continue being a paid user of Cleantalk on our 175+ sites.

    Thank you!

Viewing 12 replies - 46 through 57 (of 57 total)
  • I’m also running into the same issue here. We’re a paid user and have a lot of websites using CleanTalk as well. Would love a real resolution to this problem soon or we’ll need to find something else.

    Plugin Support amagsumov

    (@amagsumov)

    Thank you for your deedback, @frjoel

    We are currently investigating the issue and we will contact you as soon as we have any news.

    Plugin Support sergecleantalk

    (@sergecleantalk)

    Hello,

    We plan to make fixes within 2 weeks. We will inform you when the fixed version will be ready.

    Thread Starter Razorfrog Web Design

    (@razorfrog)

    Thank you, but that’s too long to wait. We’re moving our 170 sites to a more reliable system today.

    Plugin Support sergecleantalk

    (@sergecleantalk)

    Thank you for your response.

    Plugin Support sergecleantalk

    (@sergecleantalk)

    You can disable only the SpamFireWal feature for now. Anti-Spam protection will work anyway.

    Plugin Author Denis Shagy

    (@shagimuratov)

    Hi @frjoel,

    Please disable the SpamFireWall feature,
    WordPress console -> Settings -> Anti-spam by CleanTalk -> SpamFireWall off.

    Does it help?

    Also, if you put support request with your personal data here, we will do our best to solve this issue asap,
    https://cleantalk.org/my/support/open

    Plugin Author Denis Shagy

    (@shagimuratov)

    @frjoel, do you have same SQL query “SELECT COUNT(*) FROM wp_cleantalk_sfw…” in your process list?

    @razorfrog, please just disable the SpamFireWall as I wrote above, it helps to mitigate issue with stuck queries. Also, we are building an environment to simulate heavy loaded WordPress site. I hope it will help to understand why this query stuck even in Innodb tables.

    @shagimuratov It took down the site completely even after clearing the lock and restarting the server, so I had to just remove the plugin altogether. It is sporadic – I’ve been running CleanTalk for nearly a year now without trouble, but this does seem to pop up for several users. I can try to find the logs to see if it has those lines in there.

    Plugin Author Denis Shagy

    (@shagimuratov)

    @frjoel, great I’m really appreciate for any logs as well as screenshot with TOP sql queries.

    Also, as a temporary solution you can activate the plugin again with turned off option SpamFireWall. If you have same issue as @razorfrog, your site will not get this again.

    PS
    Or hold on for a few days we are going refactor some code in the backend to mitigate possible bottleneck issues.

    Plugin Support alexandergull

    (@alexandergull)

    Hello everyone, @razorfrog, @frjoel

    We have improved SQL request handling in the special version.

    Please, reinstall the plugin form this link: https://github.com/CleanTalk/wordpress-antispam/releases/download/dev-version/cleantalk-spam-protect.zip

    The guide:

    1. Go to WordPress Administrator Panel —> Plugins.
    2. Find the plugin “Spam Protection by CleanTalk” —> Deactivate.
    3. After the automatic page refresh find the plugin again “Spam Protection by CleanTalk” —> Delete. Confirm “Yes, delete these files”.
    5. Go to Plugins —> Add New —> Upload Plugin.
    4. Download the plugin archive from the link above.
    6. Choose the downloaded archive and press “Install Now”

    Please, tell us if this helps or not.

    Plugin Support SergeM

    (@serge00)

    We haven’t heard back from you in a while, so I’m going to mark this thread as “resolved”.
    If you have any further questions, you can start a new thread.

Viewing 12 replies - 46 through 57 (of 57 total)
  • The topic ‘Too many MySQL processes / killing server’ is closed to new replies.