Support » Plugin: Custom Payment Gateways for WooCommerce » Too many calls and slow average call time

  • Hi,

    I discovered in New Relic, that the plugin makes I think way too many calls and the calls are also very slow. It makes 3 to 5k calls per hour which means for every visit on the site even though it is just a payment gateway and I guess it could be called just on checkout.

    Please see these screenshots.

    I had version 1.2.0. Now upgraded to 1.4.1.

    Is there anything that can be done with this?

    Thank you.

    Kind regards

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Algoritmika Ltd


    Hi @shadyr,

    Thanks for reporting. To be honest, I’m a bit confused where this is coming from. The plugin is quite simple and I don’t think is has anything in code that could cause this. Could you please upload the screenshots of your custom payment gateways settings, so I could try to reproduce this on my test server.

    Plugin Author Algoritmika Ltd



    P.S. Not sure if it will help, but could you please try going to “WooCommerce > Settings > Custom Payment Gateways > Advanced” and setting “Shipping methods” option to “Do not load” or “Load shipping methods only”. Please let me know if that makes any difference.


    thanks for the suggestion. I have set it to Load shipping methods only. It helped a lot.

    But I think it still could be lower, so I will try Do not load as well later.

    I am sending the settings, but there is basically nothing to see I guess.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.