Support » Plugin: PhastPress » Too long filenames ending with .q.js ?

  • Resolved Hans Schuijff

    (@hanswitteprins)


    He Albert,

    I’ve been having errors in the php log recarding too long filenames and I’m wondering if it has something to do with PhastPress. I see that phastpress generates very long filenames ending on .q.js and the filenames that have been reported as being too long have such names. Can it be that the filenames you generate cause these kinds of errors?

    A reason why I have some doubt is that the files don’t have phastpress in their names, they are sought in the website root and they don’t seem to exist either. But given that I only know phastpress to use such filenames in the URLs, I hope it might be related.

    [core:error] [pid 23925] (36)File name too long: [client 66.249.66.5:46824] AH00036: access to /c2VydmljZT1idW5kbGVyJnI9LVRmU3cycW5XUkkmcj0yeUlpWG1KbzF1ZyZyPTNYd0tHMkFXVGhRJnI9NzVudVZKMVhVWTQmcj03OGNybGl6MGF2OCZyPUFOdTZUQl9GbWNvJnI9QWNjS2c1T3IwY0kmcj1DYnF0bmF3eTZDdyZyPVNfb3ZLMDllcXBrJnI9X1ZUVkZvMFJVT2Mmcj1kc05CY2JSX2pucyZyPWhYVjlSTnZjRjFZJnI9ajluTXFkNGZvbE0mcj1weWVQOWtueTRGNCZyPXJpX2pSUmFxcXVrJnI9d2o1ek4tbGZtd1Umcj14LXh0eWE2Y1paUSZyPXlUQXhHU0JsQnhJ.q.js failed (filesystem path '/home/460400.cloudwaysapps.com/txyuuwbbzk/public_html/c2VydmljZT1idW5kbGVyJnI9LVRmU3cycW5XUkkmcj0yeUlpWG1KbzF1ZyZyPTNYd0tHMkFXVGhRJnI9NzVudVZKMVhVWTQmcj03OGNybGl6MGF2OCZyPUFOdTZUQl9GbWNvJnI9QWNjS2c1T3IwY0kmcj1DYnF0bmF3eTZDdyZyPVNfb3ZLMDllcXBrJnI9X1ZUVkZvMFJVT2Mmcj1kc05CY2JSX2pucyZyPWhYVjlSTnZjRjFZJnI9ajluTXFkNGZvbE0mcj1weWVQOWtueTRGNCZyPXJpX2pSUmFxcXVrJnI9d2o1ek4tbGZtd1Umcj14LXh0eWE2Y1paUSZyPXlUQXhHU0JsQnhJ.q.js'), referer: https://dewitteprins.nl/opgroeien-emoties-en-de-ziel/

    Strangely enough all functionality seems to work on my website, so this issue doesn’t seem to block anything, but I was surprised to see the length of the filenames too.

    When I test a page using gt-metrix I see such long filenames with an url that starts with https://dewitteprins.nl/wp-content/plugins/phastpress/phast.php/

    https://dewitteprins.nl/wp-content/plugins/phastpress/phast.php/c2VydmljZT1idW5kbGVyJnI9LTRFTWIwOEp3b2Mmcj0tNVlmNWpqcUtaRSZyPTB1bXNnRTE5Mk1RJnI9MnZKbHp6eUtmWjgmcj0ydmFpVE1mZm5NRSZyPTNadG5QczlKOWdJJnI9M2hkLV9yTUtsU28mcj01OFNVUE1ib0VaTSZyPTVDM3lUUUxHVWw4JnI9OG0ycDFzLTVyNlUmcj05OGxpSEotekFzcyZyPUFWWG9PTndoRHVJJnI9QWdDMlZOUzhXZG8mcj1BckV1Sl93b3hzcyZyPUF0eW1naGpGN3EwJnI9QnhXZXRoOGctX1Umcj1DVTc0a2hfWkFOQSZyPURnSGJNbm5FVnhrJnI9RVdhNjRKNDc4TFkmcj1FY0RXMEtXTlZIdyZyPUZGYi12X1EyYVp3JnI9RzZOcEpnYUpWV28mcj1HdTBBQVdCNndSUSZyPUg4M1JNc0FKbjQwJnI9SEFiQlE5eGRWS1kmcj1JRTRQc21mM0JaUSZyPUtIMl9WYnBkSHJzJnI9TE81QWJFbGRlNHcmcj1MVm5DTnJTRHYzYyZyPUxrUHNnZlQweTdzJnI9THRhaUYtWTVGWFEmcj1MdG80VGlSS25fcyZyPU10bE5sSVN6TmtrJnI9Tk9JZ0VRb2l4c0kmcj1PMUpvczU4M3pZMCZyPU9kbl9RMVpCcjNVJnI9T3BXc19FUVhZS00mcj1QTFRPclVyYldMVSZyPVBNQ3d5QWpuXzZFJnI9UHZlR0ZQQm9ucncmcj1QeEg4Yy0xMmhrTSZyPVFoTi11SDZTY0p3JnI9UXQ0bEh0MzUtdG8mcj1SZnN4cXpmdXVlMCZyPVNHbG0zXzFOQTVJJnI9VDhOdGt1cTlMbk0mcj1UZWc4TjJFZFZ0ayZyPVdxWURjRE9fZ0hJJnI9WERNZ0o5cHpPQW8mcj1YRG5OR3pQRE9wQSZyPVhLRzdOUFh6NFJzJnI9WGJLeS10NC03MWsmcj1ZRnpSbngtTnFKZyZyPVlHRGNHc2txeHBrJnI9WjNiUTNCVzc2TU0mcj1aUE1LQW1tYzFYQSZyPV9DNnQzamljRWU0JnI9X1FsNDNoNDk2U1Umcj1hNXdyUlR1VzJNZyZyPWI3TjdwN0NuYnB3JnI9Y0J1YndWeHZFbjAmcj1lOUZEVk5FTmc0SSZyPWVFeEZVdXpNcnc0JnI9ZWE4SFhvUnZfM1kmcj1lc2s2T0k1SW9KcyZyPWZJRkFFRThjeDFVJnI9Zmt6aFptMF9JbG8mcj1mbXd2b3Y1eG9XOCZyPWh1STBJeGtSWTNFJnI9aVlNMF9HV1hLaUEmcj1qcFM4ZUdoSVM1byZyPWswNDNQemVZOV9VJnI9azZIbi1IUGoxOG8mcj1rZURwMnp0ekZxQSZyPWtqcndNdnY3S05FJnI9bEdtYWtCc0FaSkEmcj1sd1p2VTZBQlhTYyZyPW1HM1N0bk1SVG5NJnI9bjBmXzhJWWZKRG8mcj1uNWV0ZnJ0enZYWSZyPW5GeEtaSV9paDVvJnI9cEs5WDNXRUMySE0mcj1wdnlfM3QtRG9zYyZyPXMyWE5FbjdxMkE4JnI9c1dzblF1WWVhOXcmcj1zZ1p6N1ZMQUJkWSZyPXRGLThfZWp3eF9BJnI9dE5YLVJQTGVVMEEmcj11TXhKNXJVSEJpNCZyPXVvLTZ2Ni1NSEdrJnI9djlNcEpGQm9ocVUmcj12TzRkR2pJdVRtMCZyPXZZRjVOcmRxY3BrJnI9d1I5dmNlc2hpWmMmcj13X1pNWVg5eDdTSSZyPXlHTGVpSGI2ZnI0.q.js

    There it reports they are missing a cache validator. “Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources.”

    Is either familiar to you and can you perhaps offer some guidance in what to do?

    Thanks,

    Hans

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Albert Peschar

    (@kiboit)

    Hi @hanswitteprins,

    Regarding the “File name too long” error:

    These long filenames are generated by PhastPress in order to bundle many different files into a single response. It looks like these incorrect URLs are being retrieved by Google (66.249.66.5 is a Googlebot IP address).

    I don’t know why that happens, but as your site works fine in the browser, and the correct URLs are retrieved, I think it is nothing to worry about.

    You can use Google Search Console to see if Google is registering any errors for your site.

    Regarding the notice in GTmetrix about the missing ETag header:

    PhastPress does add an ETag header, but it looks like it is removed by your web server. It’s not the first time someone asks experiences this issue, and after some research it seems that the Nginx web server does this when there is no Last-Modified header.

    I’ve added the Last-Modified header in the latest version 1.74. Could you update to this version, empty your full page cache (WP Rocket) and see if the issue is resolved?

    –Albert

    Thread Starter Hans Schuijff

    (@hanswitteprins)

    Hey @kiboit ,

    Great, your update solved the cache validator issue.

    Thanks for looking into the filenames issue. I will look to search console for further info.

    Thanks,

    Hans

    ms06

    (@ms06)

    @kiboit

    Hello Albert,

    I have exactly the same errors in the logbook. Do you have any news about this ?

    Thanks in advance

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @ms06,

    Could you please post the exact log messages that you have?

    –Albert

    Bien sûr @kiboit , voici:

    2020-10-22 14:23:19 UTC [apache][core:error] [pid 18168] (36)File name too long: [client 66.249.93.199:33126] AH00036: access to /c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9Tm9ydnJPOU93VXMmcj1VUjVmQ0dpNEN3OCZyPVZKY2xmd0wtNXRnJnI9VmlEX3RPYW1Fb3Mmcj1ZRGdKM3E1U3JudyZyPVpSZ1lXQWluVzI0JnI9YXAyQTIxNjF5Z0Emcj1kNzBleUppQUdVUSZyPWVzRWJQaUh1YmhVJnI9aDg1cXRrSi04eG8mcj1qUXFsRXFEQ19GTSZyPWpnSTNuYjV0a2lJJnI9anNGWVFDaTNZaDgmcj1vaGRaOUI5VzZyNCZyPXJHOFJyb245YVowJnI9d2lmYzR6R3FSbTAmcj16SFRGZzM1dF9kTQ.q.js failed (filesystem path '/home/u839-24t3h4m587tv/www/mysitename/public_html/c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9Tm9ydnJPOU93VXMmcj1VUjVmQ0dpNEN3OCZyPVZKY2xmd0wtNXRnJn
    ‮
    2020-10-22 14:23:19 UTC [apache][core:error] [pid 20195] (36)File name too long: [client 66.249.93.197:33144] AH00036: access to /c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9Tm9ydnJPOU93VXMmcj1VUjVmQ0dpNEN3OCZyPVZKY2xmd0wtNXRnJnI9VmlEX3RPYW1Fb3Mmcj1ZRGdKM3E1U3JudyZyPVpSZ1lXQWluVzI0JnI9YXAyQTIxNjF5Z0Emcj1kNzBleUppQUdVUSZyPWVzRWJQaUh1YmhVJnI9aDg1cXRrSi04eG8mcj1qUXFsRXFEQ19GTSZyPWpnSTNuYjV0a2lJJnI9anNGWVFDaTNZaDgmcj1vaGRaOUI5VzZyNCZyPXJHOFJyb245YVowJnI9d2lmYzR6R3FSbTAmcj16SFRGZzM1dF9kTQ.q.js failed (filesystem path '/home/u839-24t3h4m587tv/www/mysitename/public_html/c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9Tm9ydnJPOU93VXMmcj1VUjVmQ0dpNEN3OCZyPVZKY2xmd0wtNXRnJn
    ‮
    2020-10-22 14:21:16 UTC [apache][core:error] [pid 8669] (36)File name too long: [client 66.249.66.67:45974] AH00036: access to /c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9TEl4ZVdyVThDQzAmcj1Ob3J2ck85T3dVcyZyPVRHQUNmSkNxUnlJJnI9VmlEX3RPYW1Fb3Mmcj1ZRGdKM3E1U3JudyZyPVpSZ1lXQWluVzI0JnI9YXAyQTIxNjF5Z0Emcj1iS1lFejRfYVhrMCZyPWQ3MGV5SmlBR1VRJnI9ZHJGUnBVWGJ2MTQmcj1lc0ViUGlIdWJoVSZyPWg4NXF0a0otOHhvJnI9alFxbEVxRENfRk0mcj1qZ0kzbmI1dGtpSSZyPWpzRllRQ2kzWWg4JnI9b2hkWjlCOVc2cjQmcj1yRzhScm9uOWFaMCZyPXdpZmM0ekdxUm0wJnI9ekhURmczNXRfZE0.q.js failed (filesystem path '/home/u839-24t3h4m587tv/www/mysitename/public_html/c2VydmljZT1idW5kbGVyJnI9M3E3OFI1OU9CTDAmcj00NWdSbmRPdF9ZVSZyPUFVcm5qb0wxTXlBJnI9Qk9YczV6cHlFc2cmcj1DUUcyVi0tcjV2USZyPUk2ZlJTcndxSFFFJnI9SWJvTUJrUzRpWDAmcj1KVmNoV0tOaU11MCZyPUpwUi1mSFQxTWxRJnI9TEl4ZVdyVThDQzAmcj1
    Thread Starter Hans Schuijff

    (@hanswitteprins)

    Hi @kiboit

    I wanted to come back on this issue too, since after our dialog (and in contact with my hosting support), I have tested if your plugin is the cause of the messages, and it appears that it is. At least: When I disable the plugin this notice doesn’t appear anymore and after activation the notice is back.

    I still don’t know why it appears, since the error notice seems to show a different url then the url that is shown when I look in dev inspector and the url points to a non existent file (as far as I found).

    To the files need to have such long filenames? That would also probably solve this.

    Hope you find something.

    Regards,

    Hans

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @hanswitteprins, @ms06,

    The reason for the long URLs is that they contain references to each script used on the page. It’s not really possible to make them much shorter.

    What is strange is that these URLs are requested at all. Normally, URLs such as the following are requested from your site:

    /wp-content/plugins/phastpress/phast.php/ABCD.q.js

    Now it seems that Google (these IP addresses are Googlebot) instead also requests these URLs:

    /ABCD.q.js

    This is what triggers the log messages.

    These log messages are harmless. However, I have just released PhastPress 1.83 which generates shorter filenames (by splitting the long filename in multiple parts). This does not change the functionality, but it should avoid these error messages.

    After updating to version 1.83, you should not see such messages in your logs anymore. It might take a while for them to disappear entirely, if Google is still visiting URLs it found earlier.

    Let me know how it goes.

    –Albert

    Hello @kiboit

    Ok great! thanks for the patch. I’m just wondering about the SEO. Can it affect SEO or is it unrelated ?

    Kind Regards

    Thread Starter Hans Schuijff

    (@hanswitteprins)

    Hi @kiboit

    Thanks for the patch, hopefully it will solve the notice.

    You have pointed before to the googlebot ip address, but that might be coincidence. I have generated the notice myself too by using the website. But the solution might be the same either case. Although if the urls are called, and not found, it might be an inefficiency somehow. Nothing seems to break, so that’s a relieve.

    Thanks,
    Hans

    Plugin Author Albert Peschar

    (@kiboit)

    @ms06, these URLs are for scripts and stylesheets. Those aren’t relevant to your SEO, so it shouldn’t make a difference.

    @hanswitteprins, if you are able to reproduce the issue visiting the website yourself, then that would be very interesting… I haven’t noticed anything like this happening myself.

    –Albert

    Hi Albert @kiboit ,

    No more error messages in the logs since the update two days ago. The problem seems to be solved on our side.

    Kind Regards

    Thread Starter Hans Schuijff

    (@hanswitteprins)

    Same here.

    regards, Hans

    Bonjour Albert,

    De nouvelles erreurs sont apparues dans le journal. Elles proviendraient de votre plugin :

    2020-10-25 06:41:02 UTC [apache][access_compat:error] [pid 47049] [client 107.178.75.23:33322] AH01797: client denied by server configuration: /home/u839-24t3h4m587tv/www/mysitename/public_html/xmlrpc.php, referer: https://mysitename/contact/
    ‮
    2020-10-25 06:40:59 UTC [apache][access_compat:error] [pid 47049] [client 199.189.255.44:33224] AH01797: client denied by server configuration: /home/u839-24t3h4m587tv/www/mysitename/public_html/xmlrpc.php, referer: https://mysitename/contact/
    ‮
    2020-10-25 06:40:56 UTC [apache][access_compat:error] [pid 48074] [client 199.189.255.40:33128] AH01797: client denied by server configuration: /home/u839-24t3h4m587tv/www/mysitename/public_html/xmlrpc.php, referer: https://mysitename/contact/
    

    Can you check on your side?

    Thanks in advance

    @kiboit

    Ps: These are not the same errors cited in previous messages.

    Regards

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @ms06,

    I think these errors have nothing to do with PhastPress. It doesn’t use xmlrpc.php.

    You get these errors because someone (probably an automated scanner looking for vulnerabilities) is trying to access your xmlrpc.php, but is blocked in your server configuration. Nothing to worry about.

    If you Google “xmlrpc wordpress” you’ll get more info.

    –Albert

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Too long filenames ending with .q.js ?’ is closed to new replies.