• Resolved inlandempireaaconvention

    (@inlandempireaaconvention)


    I am using Twenty Seventeen and WooComerce. Jetpack is constantly breaking things. It creates tons of 503 errors in the Woocommerce admin section. Pages become uneditable and have ERR_HTTP2_PROTOCOL_ERROR. I disabled Jetpack and everything worked again.

    I am not sure you are testing compatibility really well.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Stef

    (@erania-pinnera)

    Hi @inlandempireaaconvention,

    I’m sorry to hear about the trouble, but thanks for reaching out.

    As a first thing to assess your issue, can you confirm that you’re running the latest versions of both WordPress and WooCommerce?

    If that’s so, did the Jetpack conflict happen when running the last version of the plugin? We have just released the v9.6.1; you may want to try deleting Jetpack completely, install and activate this latest version and see how it goes.

    In case the issue persists and you keep getting errors, can you please copy them so we can take a look at them?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support and quote this thread as reference.

    Let me know what you find out. Thanks!

    Thread Starter inlandempireaaconvention

    (@inlandempireaaconvention)

    Thanks for the reply.

    Everything is updated to the latest. I tried to disable Woocommerce Admin and that didn’t help. I disabled Jetpack and all the problems stopped. I took a screenshot of the errors that I could share. It was essentially a lot of 503 and Json problems all in the backend and primarily with Woocommerce admin. I also had the page I was trying to edit become unable to access and the error was ERR_HTTP2_PROTOCOL_ERROR. That may have been a Json error too but I couldn’t access the page again until I disabled Jetpack.

    Plugin Contributor Stef

    (@erania-pinnera)

    Hey there, @inlandempireaaconvention,

    Thanks for the follow-up. If you have taken screenshots, we’d like to take a look at them.

    At this point, I’d like to run some more tests with you on your site to try to figure out what’s happening. Could you contact us via this contact form and mention this thread? Thanks!

    Thread Starter inlandempireaaconvention

    (@inlandempireaaconvention)

    I used your contact form and I’m being told to turn off all plugins to diagnose this issue. I can’t really do this on a live site. There is some kind of compatibility problem that is creating all these 503 errors and making Woocommerce Admin unusable.

    Plugin Contributor Jen H.

    (@jenhooks)

    Hey @inlandempireaaconvention,

    I’m seeing a few similar reports on the WooCommerce forums (here, here, and here, for example), but resolutions (if any) seem to be mixed. It’s notable that Jetpack is not a common variable.

    One of the recommendations was to increase your site’s memory limit be at least 512MB. I noticed yours was set to 256. Here’s a guide:

    https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/

    This stackoverflow thread implicates a few different things ranging from server disk space to SSL implementation.

    In short: it’s really unlikely that this is directly related to Jetpack. If you’re reluctant to toggle off plugins and change your theme on a live site, many hosts provide a staging service, where you can do testing without affecting the live site. You can ask your host about this. If they don’t give you a staging site, you could try WP Staging or Duplicator:

    https://wordpress.org/plugins/wp-staging/
    https://wordpress.org/plugins/duplicator/

    IMPORTANT NOTE: If you do create a staging site, be sure to disconnect Jetpack on the original site before cloning, otherwise, our system will become confused about which of the sites is your “real” site. Once you’ve cloned a staging site, you can then reconnect the original site back to Jetpack, and make sure you connect the staging site to Jetpack too.

    Let us know what you find.

    • This reply was modified 3 weeks, 2 days ago by Jen H..
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.