Support » Plugin: iThemes Security (formerly Better WP Security) » Tons of Database Backup emails started just during past 48 hours

  • I actually use the paid version and have the lifetime unlimited iThemes Pro license and submitted a ticket, but thought it might be good to start a topic here as well in case this is happening to anyone else.

    Starting sometime in the past 48 hours (looks like it started yesterday Dec 8th actually) the automated Database Backup feature has started sending tons of DB Backups in email on all sites I manage, despite the fact that I have the notifications set to every 6 days to 14 days on most sites. None of the sites I manage are set to send the DB Backup email more often than every 4 days, yet my inbox is full of non-stop database backups for all sites every hour at least.

    Anyone else?

Viewing 7 replies - 1 through 7 (of 7 total)
  • @anotherdave

    On Dec 7th iThemes released the Pro 4.7.0 release.

    According to the Pro 4.7.0 changelog:

    New Feature: Introduces a scheduling framework for handling events. Cron is now used by default, and will switch to using an alternate scheduling system if it detects an error. To disable this detection set ITSEC_DISABLE_CRON_TEST in your wp-config.php file.
    Important: The ITSEC_FILE_CHECK_CRON and ITSEC_BACKUP_CRON constants have been deprecated. Use ITSEC_USE_CRON instead.
    Bug Fix: Fix occasional duplicate backups and file scans.

    If your troubles started after updating to the 4.7.0 release then the newly introduced scheduling framework may be the cause of your issue.

    If so you could try and play with the ITSEC_DISABLE_CRON_TEST and/or ITSEC_USE_CRON constants in the wp-config.php file.

    Just noticed a couple of hundred emails in my inbox of backups too after updating to 4.7.0 —

    How do we set ITSEC_DISABLE_CRON_TEST in our wp-config.php file?

    define(ITSEC_DISABLE_CRON_TEST, ‘false’);

    @jaxne

    Not clearly documented but my guess (for disabling the cron test) would be:

    define(‘ITSEC_DISABLE_CRON_TEST’, true);

    And for disabling the (default) cron scheduling:

    define(‘ITSEC_USE_CRON’, false);

    Fixed in 4.7.1

    Almost fixed in 4.7.1

    It still ignores the schedule and sends DB Backup email every day even if you have it set to only run every 10 days.

    Using WP Cron ?

    If DISABLE_WP_CRON is not set to true and ITSEC_USE_CRON is not set to false in the wp-config.php you are probably using WP Cron.

    Fixed in 4.7.2 ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Tons of Database Backup emails started just during past 48 hours’ is closed to new replies.