Support » Plugin: A2 Optimized WP » Tons of cache files being created automatically…but why?

  • Resolved somanyqs

    (@somanyqs)


    I am thinking (hoping?) that the A2 plugin might be causing this issue. And maybe that there is an easy fix!

    I’ve received a nastygram from my host that I have too many files in my account (now over 1M!). This for an extremely small website that doesn’t get much traffic, and I have not created many files. I tried using the host knowledgebase but had no luck 🙁

    WP and all of my plugins are up-to-date (as of June 25).
    I have deleted my spam folder.

    I’m not a developer, I hired someone else to help make the website.

    I have found where the huge number of folders/files are:
    wp-content/cache/object/…
    I can delete all the folders, but then new ones keep getting generated.
    The general pattern is
    wp-content/cache/object/0b3/0b1/0b3xxxxxxxx.php (x’s are just random characters it seems)

    The file dates are always on today’s date. The files are all tiny (say 1.4KB).
    But it seems tens (hundreds?) of thousands exist. So I delete, and then more reappear.

    I unfortunately don’t know enough about WordPress to know how or why this is happening.
    The theme I am using is something that is custom.
    My only guess is that there is some plugin that is caching files for some reason, but I can’t figure out if that is true, and if so, how to make it stop. :-O

    Thanks much in advance for any help!

    My current plugins are:
    A2 Optimized WP
    All in One SEO Pack
    BackupBuddy
    BulletProof Secuirty
    Category Order
    Contact Form 7
    Custom Field Template
    Disqus Comment System
    Google XML Sitemaps
    Hide Admin Panels
    HTML in Caegory Descriptions
    Login LockDown
    pageMash
    postMash
    Redirection
    Rich Category Editor
    VaultPress
    Vice Versa
    WordPress Importer
    WP-CMS Post Control
    wp-jquert-lightbox
    Yet Another Featured Posts Plugin

    Email from my host:
    “It has come to our attention that your site is using an excessive number of files stored on your Bluehost account. This is causing performance problems on your website as well as for other customers that are on this server. It can cause our servers to crash and cause additional downtime.

    Our research shows that server performance degrades when accounts have over 50,000 files. In order to ensure optimal performance for your account and the others in your shared hosting environment, we request that you reduce the number of files on your account to under 300000 by 06/30/2017.

    In our most recent scan your account contained 1296276 files.

    We do understand that these files may have been created without your knowledge. There are programs/scripts that will create files automatically unless you change the settings. The following are some suggestions to help you in this process:

    Spam E-mail: If you have set up Box Trapper or Spam Assassin, you will need to log into your cPanel account and go to the Spam Assassin icon. In here you will see a Clear Spam Box button, please click on this button to empty out the spam folders.

    Caching: Some programs will use caching to speed up the loading of a page. If not properly maintained, these cache folders can grow very large. Please refer to the knowledgebase or help files for your individual program for instructions on how to clear these files.

    Log Files: Log files for most programs are stored in the root of your account in the tmp folder. You should review and clear these off the server periodically. “

Viewing 2 replies - 1 through 2 (of 2 total)
  • I have the same problem, but i am using W3 Total Cache.

    Plugin Author A2 Hosting

    (@a2hosting)

    W3 Total Cache may cause these issues. You can disable Object Caching and Database Caching through A2 Optimized to resolve this.

    We would recommend leaving Page Caching on at the very least.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Tons of cache files being created automatically…but why?’ is closed to new replies.