Support » Plugin: Broken Link Checker – Find and Fix Dead Links » Tons of broken image links are getting missed

  • Resolved ObsidianBlade

    (@obsidianblade)


    Hi,

    We used your plugin in order to try to determine whether Media Cleaner Pro, which we used to remove duplicate and unused image files from our media library, had removed any images that were actually in use. As it turns our there are a ton of missing images which MCP mistakenly removed, but Broken Link Checker has caught none of these missing images. Unfortunately all the affected pages (that we’ve detected thus far) are behind a pay wall. Please advise. Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @obsidianblade

    According to the description, the Broken Link Checker checks your posts, pages, comments, the blogroll, and custom fields.

    If the images are embedded in one of these content types, how do you embed them? Directly or via a short code? I’m not 100 percent sure, but I would assume that short codes are not checked.

    Also if you load your images via JavaScript, it could be the cause of your issues.

    The paywall probably shouldn’t matter.

    Best regards
    Marco

    I deleted some thumbnail sizes and some of my images that were used on my pages broke after that. The image links turned out to be a 404 error so I thought they would get flagged but Broken Link Checker did not catch any of them either. I just happened to come across a page and now I am manually checking every page to find broken images.

    Plugin Support Jorge – WPMU DEV Support

    (@wpmudev-support7)

    Hi @obsidianblade I’m sorry for the inconvenience on this one.

    I was wondering if you have embedded the images on a post or if you have added links to them? I’m asking this to run some tests on our end and see if we can reproduce the issue.

    Looking forward to your reply.

    Regards,

    Jorge
    WPMU DEV

    inside83

    (@boyansharic)

    I’m sorry to hijack the thread but I did the same as OP, used Media Cleaner to delete unused images and now I want to check if it did the job right.

    I only need featured images checked. This is my configuration:
    https://i.imgur.com/gRzOdMt.png
    https://i.imgur.com/EiGWKvX.png
    https://i.imgur.com/VP1p1zg.png
    https://i.imgur.com/7oeqmE7.png
    https://i.imgur.com/V5gKfH9.png

    As you can see, it says ‘No URLs in the work queue.’ but I have thousands of posts an it looks like none of them are checked.

    What’s the proper configuration?

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @boyansharic ,

    I trust you’re doing well!

    There is nothing wrong with preselected setting son your site. The message says that the plugin detected 28 unique URLs and still searching. It shows only the new URLs without the previously detected link on your site and it was still searching for new links.

    In order to force the plugin to check for brocken links, please go to Settings > Link Checker > Advanced and click on Re-check all pages.

    Are you using a theme with a Page Builder? Let us know how the images are added to posts and pages.

    Since this thread was created by another author, please open a new thread in forums and let us know how it went.

    @obsidianblade, we’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Please advise,

    Kind regards,
    Nastia

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.