Support » Plugin: Medium » Token doesn’t have necessary permissions for WordPress?

  • When trying to install my medium token it gives me this error: XXX does not have all the necessary permissions for this plugin. Please generate a new one on your Medium settings page.

    I’ve revoked and created a new one and still receiving this issue.

    What is the problem & what can I do to fix it?

    Thanks.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m having the same issue.

    I’m using WordPress 4.9.6 and Medium plugin 1.4.0.

    • This reply was modified 3 years, 6 months ago by jtimothyking. Reason: add version information

    Me too, exactly the same issue. I know Medium isn’t supporting the plugin, but hoping that someone else finds a fix…

    Thread Starter JohnnyScience

    (@johnnyscience)

    Lets hope the developer does an update soon then, I don’t know what else the fix would be if Medium doesn’t support it.

    same issue here, but this plugin is not updated since 2 years ago

    I have same problem.

    Me as well. Tried uninstalling the plugin and re-installing, tried new token, gave it 5 days to quit being cranky. Nothing seems to be working. Any solutions yet?

    I also got this message as I tried to get a new token for a new website on a domain where I already had a Medium token. No matter how many times I tried to get the new token, it kept giving me the same message. I finally just went ahead and used my existing token for the other website on the same domain, and it worked fine.
    Don’t know if anyone else is having the similar situation, but in this case, it resolved the problem.

    @mediumdotcom can you please assist in this issue?

    Has anyone here tried sending an email to yourfriends@medium.com

    This was on their plugin page.

    Medium is developed and maintained by Medium. For support, contact us at yourfriends@medium.com.

    Luis

    (@lbarraganjr)

    Same issue, hopefully its resolved soon.

    @xzykho Yes, I did. This was their reply:

    Hi Jan,

    Unfortunately, we are unable to support the WordPress plug-in any further.

    As this is an open-source tool, we suggest you file a ticket for the community to review and fix.

    Additionally, you can always manually import your stories into Medium using our import tool:
    https://medium.com/p/import

    I am sorry for the inconvenience, and if you have any specific questions please let me know.

    Thanks,
    [name Medium employee]
    User Services

    • This reply was modified 3 years, 5 months ago by Jan de Wit.

    Can @majelbstoat and @huckphin please assist? You are mentioned as ‘dev’ on the plugin page. #thanks

    Hi all!

    I’ve managed to do a hot-fix for the issue.

    You have to open file medium/inc/medium-admin.php and find function
    function personal_options_update
    And find next line within it:

    $medium_user->publications = self::get_contributing_publications($token, $user->id);

    For me this was line #183.

    Comment it out!
    For those who are non-tech users here, this means adding “//” in front of the line. So it becomes:
    // $medium_user->publications = self::get_contributing_publications($token, $user->id);

    As this is a hot-fix, the plugin might break in certain scenarios (I’ve seen getting publication function is used at some other points too). I’ve only tested simple scenario: saving integration token > posting a post > it appears on Medium > PROFIT!
    So use this fix on your own risk!

    But I am also starting to use this plugin regularly, so some other fixes might come up. Or even a whole new plugin 🙂

    If anyone is interested in backing the development and support of the plugin OR paying a reasonable amount of money for similar plugin that works and is supported – you are welcome to drop me a message at savchenko@pinedev.studio I will be really happy to know your thoughts!

    By the way, a bit of details: the reason for this current issue is that from recent time apps using integration tokens are limited in scopes. They can only make some general things with account and publish post. That’s all. They cannot list publications, for example. To have more rights in the world of Medium API, you have to create an app in settings and use OAuth tokens. But this requires much re-engineering of existing code. So for now I am happy with a hot fix that allows me to cross-post content to Medium 🙂

    Happy posting to everyone!

    Kind Regards,
    Sergii Savchenko

    Hi Sergii – thanks for the hot fix. (Didn’t try it so far, but already thank you for sharing).

    That also answers the question: Is it still possible to use the plugin. It seemed to not be possible anymore as Medium seems to close its doors for posting from the outside. But it’s still possible – yeah.

    If I happen to use the plugin, I am willing to help fixing stuff.

    @pinedev – what about a github for your hotfix?

    @pinedev Excellent work. Your hotfix worked perfectly for me. No adverse side effects yet. Thanks for your help!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Token doesn’t have necessary permissions for WordPress?’ is closed to new replies.